<!doctype html><html lang="en-US"><head>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK2SCV9');</script> <meta charset="UTF-8"><link data-optimized="2" rel="stylesheet" href="https://www.nysportsday.com/wp-content/litespeed/css/543bb59c151f9e1067dbbb22c4da3576.css?ver=3258b" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="preload" href="https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2" as="font" type="font/woff2" crossorigin><style>@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 200;
  font-display: swap;
  src: url(https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 300;
  font-display: swap;
  src: url(https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 500;
  font-display: swap;
  src: url(https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 600;
  font-display: swap;
  src: url(https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 800;
  font-display: swap;
  src: url(https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
  font-family: 'Montserrat';
  font-style: normal;
  font-weight: 900;
  font-display: swap;
  src: url(https://www.nysportsday.com/wp-content/themes/bonus/assets/fonts/JTUSjIg1_i6t8kCHKm459WlhyyTh89Y.woff2) format('woff2');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}</style> <script type="module" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.esm.js"></script> <script nomodule="" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.js"></script> <link rel="preconnect" href="https://us1.catenaus.com/" crossorigin><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <script>window.dataLayer = window.dataLayer || [];
                window.dataLayer.push({
category: `Sports Betting,US Open Tennis`,
tags: `regions:NY;vertical:sports-betting;page-type:odds;promotions:cta;events:us-open;tennis;`,
event: `Page Data`,
regionName: ``,
pageTemplate: ``
});</script> <title>U.S. Open Betting Odds and Picks</title><meta name="description" content="Check out the US Open betting odds and picks for Tuesday, Aug. 30 as the first round of the tournament concludes." /><link rel="canonical" href="https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="U.S. Open Betting Odds and Picks" /><meta property="og:description" content="Check out the US Open betting odds and picks for Tuesday, Aug. 30 as the first round of the tournament concludes." /><meta property="og:url" content="https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/" /><meta property="og:site_name" content="NY Sports Day" /><meta property="article:published_time" content="2022-08-30T15:29:38+00:00" /><meta property="og:image" content="https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="683" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Ryan Hagen" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Ryan Hagen" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="5 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/","url":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/","name":"U.S. Open Betting Odds and Picks","isPartOf":{"@id":"https://www.nysportsday.com/#website"},"primaryImageOfPage":{"@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#primaryimage"},"image":{"@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#primaryimage"},"thumbnailUrl":"https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev.jpg","datePublished":"2022-08-30T15:29:38+00:00","dateModified":"2022-08-30T15:29:38+00:00","author":{"@id":"https://www.nysportsday.com/#/schema/person/a4da474e81697a9582fcc81dafea7fc4"},"description":"Check out the US Open betting odds and picks for Tuesday, Aug. 30 as the first round of the tournament concludes.","breadcrumb":{"@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#breadcrumb"},"inLanguage":"en-US","potentialAction":{"@type":"ListenAction","target":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#podcast_player_73456","object":{"@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#/schema/podcast"}},"mainEntityOfPage":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#/schema/podcast"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#primaryimage","url":"https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev.jpg","contentUrl":"https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev.jpg","width":1024,"height":683,"caption":"Denis Shapovalov, of Canada, returns a shot to Daniil Medvedev, of Russia, during the Western &amp; Southern Open tennis tournament, Thursday, Aug. 18, 2022, in Mason, Ohio. (AP Photo/Aaron Doster)"},{"@type":"BreadcrumbList","@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.nysportsday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.nysportsday.com/news/"},{"@type":"ListItem","position":3,"name":"U.S. Open Betting Odds and Picks: Day 2, Aug. 30"}]},{"@type":"WebSite","@id":"https://www.nysportsday.com/#website","url":"https://www.nysportsday.com/","name":"NY Sports Day","description":"Your Gotham Sports News Source","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.nysportsday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.nysportsday.com/#/schema/person/a4da474e81697a9582fcc81dafea7fc4","name":"Ryan Hagen","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.nysportsday.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/5159d9247cb38232542fe8ca2f552ef3?s=96&d=retro&r=g","contentUrl":"https://secure.gravatar.com/avatar/5159d9247cb38232542fe8ca2f552ef3?s=96&d=retro&r=g","caption":"Ryan Hagen"},"description":"Ryan Hagen is a writer and contributor for NY Sports Day. He’s spent most of his career writing in roles that have ranged from copywriter at a boutique ad agency to corporate communications at a large oil firm. His true passion is sports, and he’s now been writing in the sports gaming industry for the last couple of years.","url":"https://www.nysportsday.com/author/ryan-hagen/"},{"@type":["PodcastEpisode","OnDemandEvent"],"@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#/schema/podcast","eventAttendanceMode":"https://schema.org/OnlineEventAttendanceMode","location":{"@type":"VirtualLocation","url":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/","@id":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/#webpage"},"url":"https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/","name":"U.S. Open Betting Odds and Picks","datePublished":"2022-08-30","description":"Day 1 of the US Open lived up to the hype, providing plenty of thrilling [&hellip;]"}]}</script> <style id='global-styles-inline-css' type='text/css'>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</style> <script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/073b0eb07bc32242cbdf38c34712e4b2.js?ver=97ee0' id='jquery-migrate-js'></script> <link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.nysportsday.com/feed/podcast" /><link rel="preload" as="image" fetchpriority="high" href="https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev.jpg" imagesrcset="https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev.jpg 1024w, https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev-300x200.jpg 300w, https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev-768x512.jpg 768w" imagesizes="(max-width: 1024px) 100vw, 1024px" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-180x180.png" /><meta name="msapplication-TileImage" content="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-270x270.png" /><style>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</style></head><body class="post-template-default single single-post postid-73456 single-format-standard">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PK2SCV9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><header class="site-header"><div class="bonus-mega-menu mega-menu"><ul id="menu-mega-menu" class="bonus-mega-menu-list mega-menu-list"><li id="menu-item-69904" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69904 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>What&#8217;s Popular</a><ul class="sub-menu"><li id="menu-item-69900" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69900 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/">New York Sports Betting</a></li><li id="menu-item-69901" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69901 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sportsbook Bonuses</a></li><li id="menu-item-71521" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71521 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/">Best NY Sports Odds</a></li><li id="menu-item-70304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70304 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/parlay/">Compare Parlay Odds</a></li></ul></li><li id="menu-item-69887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69887 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>NY Baseball &#038; Football</a><ul class="sub-menu"><li id="menu-item-72171" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72171 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/yankees/">NY Yankees Betting Odds</a></li><li id="menu-item-72169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72169 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/mets/">NY Mets Betting Odds</a></li><li id="menu-item-72172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72172 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/giants/">NY Giants Betting Odds</a></li><li id="menu-item-72174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72174 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/jets/">NY Jets Betting Odds</a></li></ul></li><li id="menu-item-69892" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69892 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>NY Hockey &#038; Basketball</a><ul class="sub-menu"><li id="menu-item-72173" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72173 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/rangers/">NY Rangers Betting Odds</a></li><li id="menu-item-72170" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72170 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/islanders/">NY Islanders Betting Odds</a></li><li id="menu-item-72176" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72176 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/nets/">BKN Nets Betting Odds</a></li><li id="menu-item-72175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72175 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/knicks/">NY Knicks Betting Odds</a></li></ul></li><li id="menu-item-69897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69897 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>Sportsbook Reviews</a><ul class="sub-menu"><li id="menu-item-70023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70023 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars Sportsbook NY</a></li><li id="menu-item-71519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71519 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel Sportsbook NY</a></li><li id="menu-item-71520" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71520 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/pointsbet/">PointsBet New York</a></li><li id="menu-item-71707" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71707 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers New York</a></li></ul></li></ul></div><div class="mega-menu-toggle"><div class="menu"><div class="bar"></div><div class="bar"></div><div class="bar"></div></div></div><div class="mobile-center-container"><div class="mb_link mobile_link1"><a href="https://www.nysportsday.com/sports-betting/">Sportsbooks</a></div><div class="site-branding">
<a href="https://www.nysportsday.com/" rel="home">
<span class="logo-m"><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" alt="nysportsday.com" height="344" width="500" /></span>
</a></div><div class="mb_link mobile_link2"><a href="https://www.nysportsday.com/sports-betting/bonus/">Bonuses</a></div></div><nav id="site-navigation" class="main-navigation"><div class="menu-menu-container"><ul id="primary-menu-left" class="menu"><li id="menu-item-60742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60742 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/">Sports Betting Apps</a><ul class="sub-menu"><li id="menu-item-66325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66325 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars NY</a></li><li id="menu-item-66307" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66307 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY</a></li><li id="menu-item-71726" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71726 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY</a></li><li id="menu-item-67284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67284 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/pointsbet/">PointsBet NY</a></li><li id="menu-item-66324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66324 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers NY</a></li><li id="menu-item-66326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66326 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY</a></li><li id="menu-item-67820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67820 bonus-mega-menu-item"><a href="https://www.nysportsday.com/revenue/">Revenue Info</a></li></ul></li><li id="menu-item-66331" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66331 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/bonus/">Sportsbook Bonuses</a></li><li id="menu-item-72446" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-72446 bonus-mega-menu-item"><a href="https://www.nysportsday.com/news/">NY Sports News</a></li><li id="menu-item-69700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-69700 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/">Best NY Odds</a><ul class="sub-menu"><li id="menu-item-70305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70305 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/parlay/">Parlay Betting Calculator</a></li></ul></li><li id="menu-item-65523" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65523 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sportsbooks/">Sportsbook Locations</a></li><li id="menu-item-69699" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69699 bonus-mega-menu-item"><a href="#">NY Teams</a><ul class="sub-menu"><li id="menu-item-72155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72155 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/nets/">BKN Nets</a></li><li id="menu-item-72156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72156 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/devils/">NJ Devils</a></li><li id="menu-item-72157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72157 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/giants/">NY Giants</a></li><li id="menu-item-72158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72158 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/islanders/">NY Islanders</a></li><li id="menu-item-72159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72159 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/jets/">NY Jets</a></li><li id="menu-item-72160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72160 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/knicks/">NY Knicks</a></li><li id="menu-item-72161" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72161 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/mets/">NY Mets</a></li><li id="menu-item-72162" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72162 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/rangers/">NY Rangers</a></li><li id="menu-item-72163" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72163 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/yankees/">NY Yankees</a></li></ul></li></ul></div></nav><div class="search-toggle-wrap">
<ion-icon name="search"></ion-icon></div><div class="search-form-wrap"><form role="search" aria-label="Search for:" method="get" class="search-form" action="https://www.nysportsday.com">
<label for="search-form-1">
<input type="search" id="search-form-1" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<button type="submit" class="btn btn-primary search-submit"><ion-icon name="search"></ion-icon></button></form></div></header><div id="primary" class="content-area"><main id="main" class="site-main"><article id="post-73456" class="post-73456 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-betting category-us-open-tennis"><div class="hero mb-0 post-hero image-bg"><div class="bg" style='background-image:url(https://www.nysportsday.com/wp-content/uploads/Denis-Shapovalev.jpg);'></div><div class="container"><div class="row justify-content-between"><div class="col-md-12"><div class="featured-category">
<a href="https://www.nysportsday.com/category/tennis/us-open-tennis/">
US Open Tennis </a></div><h1 class="interior-header">U.S. Open Betting Odds and Picks: Day 2, Aug. 30</h1><div class="post-meta"><div class="author"><div class="icon" style="background-image: url(https://www.nysportsday.com/wp-content/uploads/IMG_3819-Ryan-Hagen-scaled-e1658422445874-150x150.jpg);"></div><div>
<span class="lbl">Written By:</span>
<a href="https://www.nysportsday.com/author/ryan-hagen/">
Ryan Hagen </a></div></div><div class="dateblock published"><div class="icon">
<ion-icon name="newspaper-outline"></ion-icon></div><div>
<span class="lbl">Published:</span>
Aug 30, 2022</div></div><div class="dateblock updated"><div class="icon">
<ion-icon name="calendar-outline"></ion-icon></div><div>
<span class="lbl">Updated:</span>
Aug 30, 2022</div></div><div class="post-shares hide-mobile"><div class="share-box sharing"><ion-icon name="share-social-outline" style="font-size: 20px;"></ion-icon> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/" target="_blank"><div class="share-box facebook-share"><ion-icon name="logo-facebook" style="font-size: 20px;"></ion-icon> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=U.S. Open Betting Odds and Picks: Day 2, Aug. 30&url=https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/" target="_blank"><div class="share-box twitter-share"><ion-icon name="logo-twitter" style="font-size: 20px;"></ion-icon> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/&title=U.S. Open Betting Odds and Picks: Day 2, Aug. 30" target="_blank"><div class="share-box reddit-share"><ion-icon name="logo-reddit" style="font-size: 20px;"></ion-icon> <span class="seperator">|</span> Reddit</div></a></div></div></div></div></div></div><div class="entry-content"><div class="container"><div class="row"><div class="col-md-12"><p>Day 1 of the US Open lived up to the hype, providing plenty of thrilling moments from morning to night at Flushing Meadows, N.Y.</p><p>It was a day that saw dominating efforts by favorites, wild upsets by qualifiers, and a gritty win by Serena Williams, whose farewell tour lived to see at least one more match.</p><p style="text-align: center;"><a href="https://www.nysportsday.com/visit/caesars/"><strong>Score a $1,250 First Bet on Caesars with Caesars NY Promo Code SHARPBETFULL</strong></a></p><p>We’ll be tracking the action all tournament long here at NY Sports Day and will provide odds, picks, and analysis of the biggest matches each day. Let’s peek ahead at what should be an exciting second day in New York and look at a couple of massive upsets from yesterday&#8217;s action.</p><h2>U.S. Open Betting Odds and Picks for Aug. 30</h2><p>With yesterday’s matches in the history books, it’s time to see what Day 2 holds as Round 1 of the US Open finishes up. All of these betting odds are available on <a href="https://www.nysportsday.com/sports-betting/">New York&#8217;s sports betting apps</a>.</p><h3>Denis Shapovalov vs. Marc-Andrea Huesler, 3:30 p.m. ET* (estimated time)</h3><ul><li><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY</a> (Shapovalov -315; Huesler +250)</li><li><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars NY</a> (Shapovalov -320; Huesler +240)</li><li><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY</a> (Shapovalov -310; Huesler +240)</li></ul><p>This intriguing match features two players that are going in opposite directions right now.</p><p>It’s been a forgettable year for 19th-ranked Canadian Denis Shapovalov, but he has a chance to salvage his season with a strong showing at the US Open.</p><p>Shapovalov is coming off a rough stretch, in which before a couple of wins at the Western &amp; Southern Open, the Canadian had lost nine of his previous 10 contests. He also hasn’t been lighting it up on the hardcourt lately. In the 23-year-old’s last two years, he has a mediocre record of 25-20.</p><p>Meanwhile, Huesler is having a career year and looking to play spoiler. The Swiss player has a stretch of 36-21 coming into the US Open, including wins over World No. 51 Ilya Ivashka and No. 55 Jack Draper. He’s also won five of his last six matches.</p><p>Although Shapovalov is the favorite, there isn’t a lot of value in taking him on the moneyline. This will likely be a hard-fought match, and we don&#8217;t see it finishing in straight sets. Here are a couple of exciting bets available on FanDuel.</p><ul><li><strong>Both players to win a set (Yes -180/No +132):</strong> Even if Shapovalov wins, there’s a good chance he drops a set, making the ‘yes’ bet here a solid option.</li><li><strong>Marc-Andrea Huesler wins the match, and both players win a set (+370):</strong> If you’re in the mood for an upset, take this bet rather than just betting on Huesler straight up. It’s doubtful that Huesler will win in straight sets, so why not take the better odds?</li></ul><p style="text-align: center;"><strong><a class="thirstylink" title="Draftkings Sportsbook" href="https://www.nysportsday.com/visit/draftkings-sportsbook/" target="_blank" rel="nofollow noopener">This DraftKings NY Promo Code returns up to $1,050 free for tennis wagers</a></strong></p><h3>Naomi Osaka vs. Danielle Collins – 7 p.m. ET* (estimated time)</h3><ul><li>FanDuel NY (Osaka -192, Collins +158)</li><li>Caesars NY (Osaka -190, Collins +150)</li><li>DraftKings NY (Osaka -190, Collins +155)</li></ul><p>Two-time US Open winner and former world No. 1 Naomi Osaka looks to return to form after a trying couple of years. Injuries and mental health issues have been well-documented for Osaka, and she’s in danger of going a calendar year without a major title for the first time since 2017. However, she does own a 3-0 record against Danielle Collins.</p><p>Collins hasn’t had the smoothest season herself. After peaking with a finals appearance at the Australian Open, she’s struggled to regain her form in subsequent matches. The 28-year-old reached the quarterfinals in Miami but exited early in all her other tournaments.</p><p>Osaka is a slight favorite against the 19th-ranked Collins, and her 22-4 lifetime US Open record should go a long way Tuesday at Arthur Ashe Stadium. This one could go either way, with both players not in tip-top tennis shape. Here are two prop bets available at FanDuel.</p><ul><li><strong>Both players to win a set (Yes +114; No -152):</strong> With neither player dominating right now, both winning a set isn’t out of the question.</li><li><strong>To lose the first set and win the match (Osaka +500, Collins +660):</strong> If you enjoy a come-from-behind win, these odds are enticing.</li></ul><h2>Other Top Matches for US Open Day 2 Odds</h2><p>There are many intriguing matches on Day 2, including last year’s women’s champion Emma Raducanu and four-time US Open winner Rafael Nadal.</p><p>While Nadal is the top-ranked player on the men’s side (world No.2) and should cruise to a first-round victory, Raducanu’s outlook is a little murkier.</p><p>Since her historic US Open title last year, when she became the first qualifier ever to win a major, Raducanu has struggled. She’s had a series of coaching changes and hasn’t advanced past the second round in her previous three majors.</p><p>It will be an interesting match to watch as she looks to start her title defense against Cornet, a savvy veteran who has been playing well as of late.</p><ul><li><strong>Rinky Hijikata (+2000 DraftKings) vs. Rafael Nadal (-10,000 DraftKings)</strong></li><li><strong>Emma Raducanu (-155 DraftKings) vs. Alize Cornet (+130 DraftKings)</strong></li></ul><h2>Biggest Upsets From Monday&#8217;s Singles Action</h2><p>Perhaps the biggest shocker of the day came from the men’s draw when (+1200) Colombian qualifier Daniel Elahi Galan ousted (-3000) fourth-ranked Stefanos Tsitsipas of Greece. It was another blow to a depleted men’s draw that is already lacking a handful of high-profile players.</p><p>On the women’s side, former world No. 1 Simona Halep (-1800) was stunned by Ukrainian qualifier Daria Snigur (+900). It was Snigur’s first win on the WTA Tour and her first appearance in the main draw of a Grand Slam.</p><p><em>AP Photo/Aaron Doster</em></p></div></div></div><div class="post-shares show-mobile"><div class="share-box sharing"><ion-icon name="share-social-outline" style="font-size: 20px;"></ion-icon> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/" target="_blank"><div class="share-box facebook-share"><ion-icon name="logo-facebook" style="font-size: 20px;"></ion-icon> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=U.S. Open Betting Odds and Picks: Day 2, Aug. 30&url=https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/" target="_blank"><div class="share-box twitter-share"><ion-icon name="logo-twitter" style="font-size: 20px;"></ion-icon> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2022/08/30/us-open-betting-odds-aug-30/&title=U.S. Open Betting Odds and Picks: Day 2, Aug. 30" target="_blank"><div class="share-box reddit-share"><ion-icon name="logo-reddit" style="font-size: 20px;"></ion-icon> <span class="seperator">|</span> Reddit</div></a></div><div class="container mt-4"><div class="row"><div class="col-md-12"><div class="author-box card"><h5 class="card-header">About the Author</h5><div class="card-body"><div class="avatar pr-3">
<img loading="lazy" src="https://www.nysportsday.com/wp-content/uploads/IMG_3819-Ryan-Hagen-scaled-e1658422445874-300x275.jpg" width="300" height="275" /></div><div class="info"><h3 class="mb-0"><a href="https://www.nysportsday.com/author/ryan-hagen/">Ryan Hagen</h3></a><h6 class="mb-0"></h6><div class="author-socials"></div><div class="bio">
Ryan Hagen is a writer and contributor for NY Sports Day. He’s spent most of his career writing in roles that have ranged from copywriter at a boutique ad agency to corporate communications at a large oil firm. His true passion is sports, and he’s now been writing in the sports gaming industry for the last couple of years.</div></div></div></div></div></div></div></div></article></main></div><div class="social-row"><div class="container"><div class="row"><div class="col-md-4"><p>Get connected with us on Social Media</p></div><div class="col-md-8 socials">
<a href="https://www.facebook.com/nysportsday"><ion-icon name="logo-facebook"></ion-icon></a><a href="https://twitter.com/nysportsday"><ion-icon name="logo-twitter"></ion-icon></a><a href="https://www.instagram.com/nysportsday/"><ion-icon name="logo-instagram"></ion-icon></a><a href="https://www.youtube.com/user/NYSportsDay"><ion-icon name="logo-youtube"></ion-icon></a></div></div></div></div><footer class="footer-global"><div class="container"><div class="row"><div class="col-md-3"><h5>NY Sports Day</h5><p>NY Sports Day is an independent site that covers New York sports since 2004. We are fully credentialed by all nine major New York sports teams.</p></div><div class="col-md-3"><h5><a href="https://www.nysportsday.com/odds/">Best NY Sports Odds</a></h5><ul><li><a href="https://www.nysportsday.com/odds/yankees/">New York Yankees</a></li><li><a href="https://www.nysportsday.com/odds/mets/">New York Mets</a></li><li><a href="https://www.nysportsday.com/odds/giants/">New York Giants</a></li><li><a href="https://www.nysportsday.com/odds/jets/">New York Jets</a></li></ul></div><div class="col-md-3"><h5><a href="https://www.nysportsday.com/sports-betting/">NY Sports Betting &amp; Casino</a></h5><ul><li><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sportsbook Promo Codes</a></li><li><a href="https://www.nysportsday.com/revenue/">New York Revenue Info</a></li><li><a href="https://www.nysportsday.com/online-casinos/">NY Online Casinos</a></li><li><a href="https://www.nysportsday.com/sportsbooks/">NY Sportsbook Locations</a></li></ul></div><div class="col-md-3"><h5>NY Sportsbook Reviews</h5><ul><li><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars Sportsbook NY</a></li><li><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY Promo Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY Bonus Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY Promo Code</a></li></ul></div></div></div></footer><div class="footer-copyright">
Copyright © 2022 NYSportsDay - All rights reserved. <a href="https://www.nysportsday.com/about/">About </a> | <a href="https://www.nysportsday.com/contact/">Contact </a> | <a href="https://www.nysportsday.com/privacy-policy/">Privacy Policy</a> | <a href="https://www.nysportsday.com/responsible-gaming/">Responsible Gaming</a></div><div class="modal fade" id="gameModal" tabindex="-1" role="dialog" aria-labelledby="gameModalLabel" aria-hidden="true"><div class="modal-dialog modal-dialog-centered" role="document"><div class="modal-content"><div class="modal-header"><h5 class="modal-title" id="gameModalLabel">Modal title</h5>
<button type="button" class="close" data-dismiss="modal" aria-label="Close">
<span aria-hidden="true">&times;</span>
</button></div><div class="modal-body">
<iframe width="100%" height="550" src=""></iframe></div></div></div></div> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/2b97f72de303df3adba850245ca07423.js?ver=97548' id='chub-get-cta-v2-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/a39eef2b6e8c2e244829b67a5a3a2cc6.js?ver=6f7dc' id='regenerator-runtime-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/d4998cb41d67d730b95df1a2fd5fa348.js?ver=f46f5' id='wp-polyfill-js'></script> <script type='text/javascript' id='contact-form-7-js-extra'>/*  */
var wpcf7 = {"api":{"root":"https:\/\/www.nysportsday.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/c3647deab36393f7518d164ba5911d47.js?ver=605ae' id='contact-form-7-js'></script> <script type='text/javascript' id='ta_main_js-js-extra'>/*  */
var thirsty_global_vars = {"home_url":"\/\/www.nysportsday.com","ajax_url":"https:\/\/www.nysportsday.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"visit","link_prefixes":["recommends","visit"],"post_id":"73456","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/ce961e5692c311e29b501357440157b0.js?ver=d52c4' id='ta_main_js-js'></script> <script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/aa66b29fa0a299739181b3d258f4608f.js?ver=b4c15' id='bootstrap-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/f95bd4f5fea43fbce913065137f79d20.js?ver=991ca' id='globaljs-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/bec53e075b4af67d999068175e75863f.js?ver=fbe29' id='bonus_mega_menu-js'></script> <script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":73456,"object_key":"post","object_type":"post","term_ids":[21263,27],"wp_json":"https:\/\/www.nysportsday.com\/wp-json"};</script> </body></html>

