<!doctype html><html lang="en-US"><head>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK2SCV9');</script> <meta charset="UTF-8"><link data-optimized="2" rel="stylesheet" href="https://www.nysportsday.com/wp-content/litespeed/css/12bd278867d2c71bd8be38f3637dc61b.css?ver=aedd6" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="profile" href="https://gmpg.org/xfn/11"><link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&display=swap" rel="stylesheet"> <script type="module" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.esm.js"></script> <script nomodule="" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.js"></script> <link rel="preconnect" href="https://us1.catenaus.com/" crossorigin><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <script>window.dataLayer = window.dataLayer || [];
                window.dataLayer.push({
category: `Football`,
tags: ``,
event: `Page Data`,
regionName: ``,
pageTemplate: ``
});</script> <title>Surging USFL Generals Are Area&#039;s Best-Kept Secret - NY Sports Day</title><link rel="canonical" href="https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Surging USFL Generals Are Area&#039;s Best-Kept Secret - NY Sports Day" /><meta property="og:description" content="What is the best kept sports secret in the New York/New jersey area? Try the [&hellip;]" /><meta property="og:url" content="https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/" /><meta property="og:site_name" content="NY Sports Day" /><meta property="article:published_time" content="2022-06-16T01:50:12+00:00" /><meta property="og:image" content="https://www.nysportsday.com/wp-content/uploads/AP22126635951544.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="683" /><meta property="og:image:type" content="image/jpeg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Jeff Moeller" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="3 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.nysportsday.com/#website","url":"https://www.nysportsday.com/","name":"NY Sports Day","description":"Your Gotham Sports News Source","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.nysportsday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#primaryimage","url":"https://www.nysportsday.com/wp-content/uploads/AP22126635951544.jpg","contentUrl":"https://www.nysportsday.com/wp-content/uploads/AP22126635951544.jpg","width":1024,"height":683,"caption":"FILE - New Jersey Generals Braedon Bowman tight end (80) catches a pass for a touchdown as Birmingham Stallions cornerback Brian Allen (29) defends during the first half of a USFL football game Saturday, April 16, 2022, in Birmingham, Ala. A revived United States Football League — borrowing the moniker and team nicknames from a league that went out of business 36 years ago — launched last month with all regular-season games being played in Birmingham. (AP Photo/Butch Dill, File)"},{"@type":"WebPage","@id":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#webpage","url":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/","name":"Surging USFL Generals Are Area's Best-Kept Secret - NY Sports Day","isPartOf":{"@id":"https://www.nysportsday.com/#website"},"primaryImageOfPage":{"@id":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#primaryimage"},"datePublished":"2022-06-16T01:50:12+00:00","dateModified":"2022-06-16T01:50:12+00:00","author":{"@id":"https://www.nysportsday.com/#/schema/person/74d8ac2cf9435309394e9c408aadccc0"},"breadcrumb":{"@id":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#breadcrumb"},"inLanguage":"en-US","potentialAction":{"@type":"ListenAction","target":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#podcast_player_71279","object":{"@id":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#/schema/podcast"}},"mainEntityOfPage":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#/schema/podcast"},{"@type":"BreadcrumbList","@id":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.nysportsday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.nysportsday.com/news/"},{"@type":"ListItem","position":3,"name":"Surging USFL Generals Are Area&#8217;s Best-Kept Secret"}]},{"@type":"Person","@id":"https://www.nysportsday.com/#/schema/person/74d8ac2cf9435309394e9c408aadccc0","name":"Jeff Moeller","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.nysportsday.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/266030fb3d64ae665d9cc58293c52a5b?s=96&d=retro&r=g","contentUrl":"https://secure.gravatar.com/avatar/266030fb3d64ae665d9cc58293c52a5b?s=96&d=retro&r=g","caption":"Jeff Moeller"},"url":"https://www.nysportsday.com/author/jeff-moeller/"},{"@type":["PodcastEpisode","OnDemandEvent"],"@id":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#/schema/podcast","eventAttendanceMode":"https://schema.org/OnlineEventAttendanceMode","location":{"@type":"VirtualLocation","url":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/","@id":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/#webpage"},"url":"https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/","name":"Surging USFL Generals Are Area's Best-Kept Secret - NY Sports Day","datePublished":"2022-06-15","description":"What is the best kept sports secret in the New York/New jersey area? Try the [&hellip;]"}]}</script> <style id='global-styles-inline-css' type='text/css'>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</style> <script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/073b0eb07bc32242cbdf38c34712e4b2.js?ver=97ee0' id='jquery-migrate-js'></script> <link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.nysportsday.com/feed/podcast" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-180x180.png" /><meta name="msapplication-TileImage" content="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-270x270.png" /><style>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</style></head><body class="post-template-default single single-post postid-71279 single-format-standard">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PK2SCV9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><header class="site-header"><div class="bonus-mega-menu mega-menu"><ul id="menu-mega-menu" class="bonus-mega-menu-list mega-menu-list"><li id="menu-item-69887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69887 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>NY Baseball &#038; Football</a><ul class="sub-menu"><li id="menu-item-69888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69888 bonus-mega-menu-item"><a href="https://www.nysportsday.com/yankees/">New York Yankees</a></li><li id="menu-item-69889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69889 bonus-mega-menu-item"><a href="https://www.nysportsday.com/mets/">New York Mets</a></li><li id="menu-item-69890" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69890 bonus-mega-menu-item"><a href="https://www.nysportsday.com/giants/">New York Giants</a></li><li id="menu-item-69891" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69891 bonus-mega-menu-item"><a href="https://www.nysportsday.com/jets/">New York Jets</a></li></ul></li><li id="menu-item-69892" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69892 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>NY Hockey &#038; Basketball</a><ul class="sub-menu"><li id="menu-item-69893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69893 bonus-mega-menu-item"><a href="https://www.nysportsday.com/islanders/">New York Islanders</a></li><li id="menu-item-69894" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69894 bonus-mega-menu-item"><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li><li id="menu-item-69895" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69895 bonus-mega-menu-item"><a href="https://www.nysportsday.com/knicks/">New York Knicks</a></li><li id="menu-item-69896" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69896 bonus-mega-menu-item"><a href="https://www.nysportsday.com/nets/">Brooklyn Nets</a></li></ul></li><li id="menu-item-69897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69897 bonus-mega-menu-item-expand-submenu bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>Sports Betting</a><ul class="sub-menu"><li id="menu-item-69900" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69900 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/">New York Sports Betting</a></li><li id="menu-item-69901" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69901 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sportsbook Bonuses</a></li><li id="menu-item-69902" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69902 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings Sportsbook NY</a></li><li id="menu-item-70023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70023 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars Sportsbook NY</a></li></ul></li><li id="menu-item-69904" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69904 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>Tools &#038; Contact</a><ul class="sub-menu"><li id="menu-item-70304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70304 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/parlay/">Compare Parlay Odds</a></li><li id="menu-item-69906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69906 bonus-mega-menu-item"><a href="https://www.nysportsday.com/about/">About</a></li><li id="menu-item-69905" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69905 bonus-mega-menu-item"><a href="https://www.nysportsday.com/contact/">Contact</a></li></ul></li></ul></div><div class="mega-menu-toggle"><div class="menu"><div class="bar"></div><div class="bar"></div><div class="bar"></div></div></div><div class="mobile-center-container"><div class="mb_link mobile_link1"><a href="https://www.nysportsday.com/sports-betting/">Sportsbooks</a></div><div class="site-branding">
<a href="https://www.nysportsday.com/" rel="home">
<span class="logo-m"><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" alt="nysportsday.com" height="344" width="500" /></span>
</a></div><div class="mb_link mobile_link2"><a href="https://www.nysportsday.com/sports-betting/bonus/">Bonuses</a></div></div><nav id="site-navigation" class="main-navigation"><div class="menu-menu-container"><ul id="primary-menu-left" class="menu"><li id="menu-item-60742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60742 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/">Sports Betting Apps</a><ul class="sub-menu"><li id="menu-item-66325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66325 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars NY</a></li><li id="menu-item-66307" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66307 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY</a></li><li id="menu-item-64261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64261 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY</a></li><li id="menu-item-67284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67284 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/pointsbet/">PointsBet NY</a></li><li id="menu-item-66324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66324 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers NY</a></li><li id="menu-item-66326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66326 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY</a></li><li id="menu-item-67820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67820 bonus-mega-menu-item"><a href="https://www.nysportsday.com/revenue/">Revenue Info</a></li></ul></li><li id="menu-item-66331" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66331 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/bonus/">Sportsbook Bonuses</a></li><li id="menu-item-69700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-69700 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/">Best NY Odds</a><ul class="sub-menu"><li id="menu-item-70305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70305 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/parlay/">Compare Parlay Odds</a></li></ul></li><li id="menu-item-65523" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65523 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sportsbooks/">Sportsbook Locations</a></li><li id="menu-item-69699" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69699 bonus-mega-menu-item"><a href="#">NY Teams</a><ul class="sub-menu"><li id="menu-item-56860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56860 bonus-mega-menu-item"><a href="https://www.nysportsday.com/nets/">BKN Nets</a></li><li id="menu-item-56857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56857 bonus-mega-menu-item"><a href="https://www.nysportsday.com/devils/">NJ Devils</a></li><li id="menu-item-56863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56863 bonus-mega-menu-item"><a href="https://www.nysportsday.com/giants/">NY Giants</a></li><li id="menu-item-56858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56858 bonus-mega-menu-item"><a href="https://www.nysportsday.com/islanders/">NY Islanders</a></li><li id="menu-item-56862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56862 bonus-mega-menu-item"><a href="https://www.nysportsday.com/jets/">NY Jets</a></li><li id="menu-item-56861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56861 bonus-mega-menu-item"><a href="https://www.nysportsday.com/knicks/">NY Knicks</a></li><li id="menu-item-56864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56864 bonus-mega-menu-item"><a href="https://www.nysportsday.com/mets/">NY Mets</a></li><li id="menu-item-56859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56859 bonus-mega-menu-item"><a href="https://www.nysportsday.com/rangers/">NY Rangers</a></li><li id="menu-item-56865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56865 bonus-mega-menu-item"><a href="https://www.nysportsday.com/yankees/">NY Yankees</a></li></ul></li><li id="menu-item-56830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56830 bonus-mega-menu-item"><a href="#">Columnists</a><ul class="sub-menu"><li id="menu-item-56273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56273 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</a></li><li id="menu-item-56272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56272 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/hal-bock/">Hal Bock</a></li><li id="menu-item-56279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56279 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/leslie-treff/">Leslie Treff</a></li><li id="menu-item-56278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56278 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/admin/">Joe McDonald</a></li><li id="menu-item-60167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60167 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/esposito/">Andy Esposito</a></li><li id="menu-item-56275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56275 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/lloyd-carroll/">Lloyd Carroll</a></li><li id="menu-item-56276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56276 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/jeff-moeller/">Jeff Moeller</a></li><li id="menu-item-56274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56274 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/howie-karpin/">Howie Karpin</a></li><li id="menu-item-56277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56277 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/david-russell/">David Russell</a></li></ul></li></ul></div></nav><div class="search-toggle-wrap">
<ion-icon name="search"></ion-icon></div><div class="search-form-wrap"><form role="search" aria-label="Search for:" method="get" class="search-form" action="https://www.nysportsday.com">
<label for="search-form-1">
<input type="search" id="search-form-1" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<button type="submit" class="btn btn-primary search-submit"><ion-icon name="search"></ion-icon></button></form></div></header><div id="primary" class="content-area"><main id="main" class="site-main"><article id="post-71279" class="post-71279 post type-post status-publish format-standard has-post-thumbnail hentry category-football"><div class="hero mb-0 post-hero detached-image"><div class="bg"></div><div class="container"><div class="row justify-content-between"><div class="col-md-12"><div class="featured-category">
<a href="https://www.nysportsday.com/category/football/">
Football </a></div><h1 class="interior-header">Surging USFL Generals Are Area&#8217;s Best-Kept Secret</h1><div class="post-meta"><div class="author"><div class="icon">
<ion-icon name="person-circle-outline"></ion-icon></div><div>
<span class="lbl">Written By:</span>
<a href="https://www.nysportsday.com/author/jeff-moeller/">
Jeff Moeller </a></div></div><div class="dateblock published"><div class="icon">
<ion-icon name="newspaper-outline"></ion-icon></div><div>
<span class="lbl">Published:</span>
Jun 15, 2022</div></div><div class="dateblock updated"><div class="icon">
<ion-icon name="calendar-outline"></ion-icon></div><div>
<span class="lbl">Updated:</span>
Jun 15, 2022</div></div><div class="post-shares hide-mobile"><div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=Surging USFL Generals Are Area&#8217;s Best-Kept Secret&url=https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/&title=Surging USFL Generals Are Area&#8217;s Best-Kept Secret" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a></div></div></div></div></div></div><div class="entry-content"><div class="container"><div class="row"><div class="col-md-12"><div class="detached-image">
<img src="https://www.nysportsday.com/wp-content/uploads/AP22126635951544.jpg" width="1024" height="683" /></div><p><span style="font-weight: 400">What is the best kept sports secret in the New York/New jersey area?</span></p><p><span style="font-weight: 400">Try the New Jersey Generals.</span></p><p><span style="font-weight: 400">Those are the same New Jersey Generals of the mid-1980s that featured Herschel Walker and Doug Flutie. They even had Donald Trump as their owner.</span></p><p><span style="font-weight: 400">These Generals will enter their game against the Philadelphia Stars Sunday winner of eight consecutive games (8-1) and have an undefeated record in the league’s North division.</span></p><p><span style="font-weight: 400"> They will play the same Stars team the following week in the opening-round of the league playoffs in Canton, Ohio – in case you don’t recognize it, Canton is where the NFL Hall of Fame is located.</span></p><p><span style="font-weight: 400">This group of Generals has an identity problem, and it is no fault of their own. All of the league’s games have been played in Birmingham, Alabama. That’s great for the home Stallions, who are also in the playoffs.</span></p><p><span style="font-weight: 400">Yet, attendance for games overall hasn’t been bad, and it has naturally tailed off since the opening week.</span></p><p><span style="font-weight: 400">ABC and FOX have been a major reason for their continued existence, and their weekly ratings share hovered around the 20 million mark. Again, it isn’t bad.</span></p><p><span style="font-weight: 400">However, if these Generals were playing their home games, you would come. Spring football in New Jersey could work. </span></p><p><span style="font-weight: 400">You may have been one of the fans who watched the short-lived XFL Guardians, who arguably brought some excitement in the spring.</span></p><p><span style="font-weight: 400">These Generals have been led by running back Darius Victor, who has been among the league’s top three rushers all season, and has helped them grind out an average of 160 yards per game.</span></p><p><span style="font-weight: 400">The Generals are one of the few teams in professional football history who successfully implemented a two-quarterback system with Luis Perez and De’Andre Johnson. Perez is a castoff from the Guardians, and he is one of the more recognizable names from the old franchise.</span></p><p><span style="font-weight: 400">KaVontae Turpin has established himself as a premier return man, and he has the league’s only punt return – a 71-yarder &#8211; for a score.</span></p><p><span style="font-weight: 400">Turpin also leads the team in receptions and yards and has emerged as a top-flite and consistent receiver and should get some NFL looks. In addition, Darrius Shepherd is a consistent receiver who gives the Generals a productive tandem.</span></p><p><span style="font-weight: 400">Linebackers Chris Orr (team-leading 74 tackles) and Chris Orr (63) have paced the defense, and Shalom Luani (team-high four interceptions) and Dravon Askew-Henry have led a shutdown secondary. Overall, the defense has allowed a league-low 17.6 points per game.</span></p><p><span style="font-weight: 400">Head coach Mike Riley has already formed a blue-collar, hard-working environment that has produced a tight-knit, supportive chemistry among his players. There is a growing consensus that Riley can lead the Generals to the inaugural league title.</span></p><p><span style="font-weight: 400">Remember these names. Some of them may show up on NFL rosters this August, but more importantly, they can be back on the Generals’ roster next spring. Oh, Duane “The Rock” Johnson is relaunching the XFL next year at some point, and New York/ New Jersey could land a franchise. </span></p><p><span style="font-weight: 400">Keep an eye on the Generals the next few weeks. They are fun to watch, and there is a good quality of football.</span></p><p><span style="font-weight: 400">Next spring, the USFL hopefully will be back, and the Generals will be back at the Meadowlands. </span></p><p><span style="font-weight: 400">You know you will try and get a ticket to be there.</span></p><p>&nbsp;</p></div></div></div><div class="post-shares show-mobile"><div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=Surging USFL Generals Are Area&#8217;s Best-Kept Secret&url=https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2022/06/15/surging-usfl-generals-are-areas-best-kept-secret/&title=Surging USFL Generals Are Area&#8217;s Best-Kept Secret" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a></div><div class="container mt-4"><div class="row"><div class="col-md-12"><div class="author-box card"><h5 class="card-header">About the Author</h5><div class="card-body"><div class="info"><h3 class="mb-0"><a href="https://www.nysportsday.com/author/jeff-moeller/">Jeff Moeller</h3></a><h6 class="mb-0"></h6><div class="author-socials"></div><div class="bio"></div></div></div></div></div></div></div></div></article></main></div><div class="social-row"><div class="container"><div class="row"><div class="col-md-4"><p>Get connected with us on Social Media</p></div><div class="col-md-8 socials">
<a href="https://www.facebook.com/nysportsday"><i class="dashicons dashicons-facebook-alt"></i></a><a href="https://twitter.com/nysportsday"><i class="dashicons dashicons-twitter"></i></a><a href="https://www.instagram.com/nysportsday/"><i class="dashicons dashicons-instagram"></i></a><a href="https://www.youtube.com/user/NYSportsDay"><i class="dashicons dashicons-youtube"></i></a></div></div></div></div><footer class="footer-global"><div class="container"><div class="row"><div class="col-md-3"><h5>NY Sports Day</h5><p>NY Sports Day is an independent site that covers New York sports since 2004. We are fully credentialed by all nine major New York sports teams.</p></div><div class="col-md-3"><h5>NY Sports</h5><ul><li><a href="/yankees/">New York Yankees</a></li><li><a href="https://www.nysportsday.com/mets/">New York Mets</a></li><li><a href="https://www.nysportsday.com/giants/">New York Giants</a></li><li><a href="https://www.nysportsday.com/jets/">New York Jets</a></li></ul></div><div class="col-md-3"><h5><a href="https://www.nysportsday.com/sports-betting/">NY Sports Betting</a></h5><ul><li><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY Promo Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY Bonus Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars Sportsbook NY</a></li><li><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers NY </a></li></ul></div><div class="col-md-3"><h5>NY Sportsbook Reviews</h5><ul><li><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY Promo Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/pointsbet/">PointsBet NY</a></li><li><a href="https://www.nysportsday.com/sports-betting/wynnbet/">WynnBET NY</a></li><li><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sportsbook Promo Codes</a></li></ul></div></div></div></footer><div class="footer-copyright">
Copyright © 2022 NYSportsDay - All rights reserved. <a href="https://www.nysportsday.com/about/">About </a> | <a href="https://www.nysportsday.com/contact/">Contact </a> | <a href="https://www.nysportsday.com/privacy-policy/">Privacy Policy</a> | <a href="https://www.nysportsday.com/responsible-gaming/">Responsible Gaming</a></div><div class="modal fade" id="gameModal" tabindex="-1" role="dialog" aria-labelledby="gameModalLabel" aria-hidden="true"><div class="modal-dialog modal-dialog-centered" role="document"><div class="modal-content"><div class="modal-header"><h5 class="modal-title" id="gameModalLabel">Modal title</h5>
<button type="button" class="close" data-dismiss="modal" aria-label="Close">
<span aria-hidden="true">&times;</span>
</button></div><div class="modal-body">
<iframe width="100%" height="550" src=""></iframe></div></div></div></div> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/2b97f72de303df3adba850245ca07423.js?ver=97548' id='chub-get-cta-v2-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/a39eef2b6e8c2e244829b67a5a3a2cc6.js?ver=6f7dc' id='regenerator-runtime-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/d4998cb41d67d730b95df1a2fd5fa348.js?ver=f46f5' id='wp-polyfill-js'></script> <script type='text/javascript' id='contact-form-7-js-extra'>/*  */
var wpcf7 = {"api":{"root":"https:\/\/www.nysportsday.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/c3647deab36393f7518d164ba5911d47.js?ver=30148' id='contact-form-7-js'></script> <script type='text/javascript' id='ta_main_js-js-extra'>/*  */
var thirsty_global_vars = {"home_url":"\/\/www.nysportsday.com","ajax_url":"https:\/\/www.nysportsday.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"visit","link_prefixes":["recommends","visit"],"post_id":"71279","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/ce961e5692c311e29b501357440157b0.js?ver=d52c4' id='ta_main_js-js'></script> <script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/aa66b29fa0a299739181b3d258f4608f.js?ver=3349a' id='bootstrap-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/f95bd4f5fea43fbce913065137f79d20.js?ver=e3626' id='globaljs-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/bec53e075b4af67d999068175e75863f.js?ver=fbe29' id='bonus_mega_menu-js'></script> <script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":71279,"object_key":"post","object_type":"post","term_ids":[13]};</script> </body></html>

