<!doctype html><html lang="en-US"><head>
 <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK2SCV9');</script> <meta charset="UTF-8"><link data-optimized="2" rel="stylesheet" href="https://www.nysportsday.com/wp-content/litespeed/css/37816e7cb72c8df5dbff0ee16ce29a1a.css?ver=9c64d" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="profile" href="https://gmpg.org/xfn/11"><link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&display=swap" rel="stylesheet"> <script type="module" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.esm.js"></script> <script nomodule="" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.js"></script> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><title>UFC 268 Betting Odds And Analysis — Usman Vs. Covington</title><meta name="description" content="A rematch between Kamaru Usman and Colby Covington highlights UFC 268 at Madison Square Garden. Check out the betting odds and analysis." /><link rel="canonical" href="https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="UFC 268 Betting Odds And Analysis — Usman Vs. Covington" /><meta property="og:description" content="A rematch between Kamaru Usman and Colby Covington highlights UFC 268 at Madison Square Garden. Check out the betting odds and analysis." /><meta property="og:url" content="https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/" /><meta property="og:site_name" content="NY Sports Day" /><meta property="article:published_time" content="2021-11-04T15:45:38+00:00" /><meta property="article:modified_time" content="2021-11-04T16:08:11+00:00" /><meta property="og:image" content="https://www.nysportsday.com/wp-content/uploads/UFC-announcer-scaled.jpg" /><meta property="og:image:width" content="2560" /><meta property="og:image:height" content="1707" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Derrel Johnson" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="2 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.nysportsday.com/#website","url":"https://www.nysportsday.com/","name":"NY Sports Day","description":"Your Gotham Sports News Source","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.nysportsday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/#primaryimage","inLanguage":"en-US","url":"https://www.nysportsday.com/wp-content/uploads/UFC-announcer-scaled.jpg","contentUrl":"https://www.nysportsday.com/wp-content/uploads/UFC-announcer-scaled.jpg","width":2560,"height":1707,"caption":"UFC 268 will take place at Madison Square Garden on Nov. 6."},{"@type":"WebPage","@id":"https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/#webpage","url":"https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/","name":"UFC 268 Betting Odds And Analysis \u2014 Usman Vs. Covington","isPartOf":{"@id":"https://www.nysportsday.com/#website"},"primaryImageOfPage":{"@id":"https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/#primaryimage"},"datePublished":"2021-11-04T15:45:38+00:00","dateModified":"2021-11-04T16:08:11+00:00","author":{"@id":"https://www.nysportsday.com/#/schema/person/083b1e1edb3c1ca418e8d4ad07d0e40e"},"description":"A rematch between Kamaru Usman and Colby Covington highlights UFC 268 at Madison Square Garden. Check out the betting odds and analysis.","breadcrumb":{"@id":"https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/"]}]},{"@type":"BreadcrumbList","@id":"https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.nysportsday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.nysportsday.com/news/"},{"@type":"ListItem","position":3,"name":"UFC 268 Betting Odds And Analysis \u2014 Usman Vs. Covington"}]},{"@type":"Person","@id":"https://www.nysportsday.com/#/schema/person/083b1e1edb3c1ca418e8d4ad07d0e40e","name":"Derrel Johnson","image":{"@type":"ImageObject","@id":"https://www.nysportsday.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/86d6ebafaf4446a28df8ab5e29ffb988?s=96&d=retro&r=g","contentUrl":"https://secure.gravatar.com/avatar/86d6ebafaf4446a28df8ab5e29ffb988?s=96&d=retro&r=g","caption":"Derrel Johnson"},"url":"https://www.nysportsday.com/author/derrel-johnson/"}]}</script>  <script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/073b0eb07bc32242cbdf38c34712e4b2.js?ver=97ee0' id='jquery-migrate-js'></script> <link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.nysportsday.com/feed/podcast" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-180x180.png" /><meta name="msapplication-TileImage" content="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-270x270.png" /></head><body class="post-template-default single single-post postid-63738 single-format-standard">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PK2SCV9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><header class="site-header"><div class="mega-menu"><div class="logo-col"><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" /></div><div class="container"><div class="row"><div class="col-md-6"><h4 class="mm-nav-label">NY Baseball &amp; Football</h4><ul><li><a href="/yankees/">New York Yankees</a></li><li><a href="https://www.nysportsday.com/category/baseball/new-york-mets/">New York Mets</a></li><li><a href="https://www.nysportsday.com/category/football/new-york-giants/">New York Giants</a></li><li><a href="https://www.nysportsday.com/category/football/new-york-jets/">New York Jets</a></li></ul></div><div class="col-md-6"><h4 class="mm-nav-label">NY Hockey &amp; Basketball</h4><ul><li><a href="https://www.nysportsday.com/category/hockey/new-york-islanders/">New York Islanders</a></li><li><a href="https://www.nysportsday.com/category/hockey/new-york-rangers/">New York Rangers</a></li><li><a href="https://www.nysportsday.com/category/basketball/new-york-knicks/">New York Knicks</a></li><li><a href="https://www.nysportsday.com/category/basketball/new-jersey-nets/">Brooklyn Nets</a></li></ul></div><div class="col-md-6"><h4 class="mm-nav-label">Other</h4><ul><li><a href="https://www.nysportsday.com/new-york-sports-betting/">New York Sports Betting</a></li></ul></div><div class="col-md-6"><h4 class="mm-nav-label">Contact</h4><ul><li><a href="https://www.nysportsday.com/about/">About</a></li><li><a href="https://www.nysportsday.com/contact-us/">Contact</a></li></ul></div></div></div></div><div class="mega-menu-toggle"><div class="menu"><div class="bar"></div><div class="bar"></div><div class="bar"></div></div></div><div class="site-branding">
<a href="https://www.nysportsday.com/" rel="home">
<span class="logo-m"><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" alt="nysportsday.com"/></span>
</a></div><nav id="site-navigation" class="main-navigation"><div class="menu-menu-container"><ul id="primary-menu-left" class="menu"><li id="menu-item-15689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-15689"><a href="https://www.nysportsday.com/">Home</a></li><li id="menu-item-15690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15690"><a href="https://www.nysportsday.com/category/baseball/">Baseball</a><ul class="sub-menu"><li id="menu-item-56865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56865"><a href="https://www.nysportsday.com/yankees/">NY Yankees</a></li><li id="menu-item-56864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56864"><a href="https://www.nysportsday.com/mets/">NY Mets</a></li></ul></li><li id="menu-item-15693" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15693"><a href="https://www.nysportsday.com/category/football/">Football</a><ul class="sub-menu"><li id="menu-item-56862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56862"><a href="https://www.nysportsday.com/jets/">NY Jets News</a></li><li id="menu-item-56863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56863"><a href="https://www.nysportsday.com/giants/">NY Giants</a></li></ul></li><li id="menu-item-15696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15696"><a href="https://www.nysportsday.com/category/basketball/">Basketball</a><ul class="sub-menu"><li id="menu-item-56860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56860"><a href="https://www.nysportsday.com/nets/">Brooklyn Nets</a></li><li id="menu-item-56861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56861"><a href="https://www.nysportsday.com/knicks/">NY Knicks</a></li></ul></li><li id="menu-item-15699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15699"><a href="https://www.nysportsday.com/category/hockey/">Hockey</a><ul class="sub-menu"><li id="menu-item-56858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56858"><a href="https://www.nysportsday.com/islanders/">NY Islanders</a></li><li id="menu-item-56859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56859"><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li><li id="menu-item-56857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56857"><a href="https://www.nysportsday.com/devils/">NJ Devils</a></li></ul></li><li id="menu-item-15711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15711"><a href="https://www.nysportsday.com/category/other-sports/">Other</a><ul class="sub-menu"><li id="menu-item-15718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15718"><a href="https://www.nysportsday.com/category/tennis/us-open-tennis/">US Open Tennis</a></li><li id="menu-item-15712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15712"><a href="https://www.nysportsday.com/category/boxing/">Boxing</a></li><li id="menu-item-15713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15713"><a href="https://www.nysportsday.com/category/golf/">Golf</a></li><li id="menu-item-15714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15714"><a href="https://www.nysportsday.com/category/soccer/new-york-cosmos/">New York Cosmos</a></li><li id="menu-item-15715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15715"><a href="https://www.nysportsday.com/category/soccer/new-york-red-bulls/">New York Red Bulls</a></li><li id="menu-item-16038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16038"><a href="https://www.nysportsday.com/category/soccer/nycfc/">NYC FC</a></li><li id="menu-item-15729" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15729"><a href="https://www.nysportsday.com/category/college/college-basketball/">College Basketball</a></li><li id="menu-item-15730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15730"><a href="https://www.nysportsday.com/category/college/college-football/">College Football</a></li></ul></li><li id="menu-item-56830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56830"><a href="#">Columnists</a><ul class="sub-menu"><li id="menu-item-56273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56273"><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</a></li><li id="menu-item-56272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56272"><a href="https://www.nysportsday.com/author/hal-bock/">Hal Bock</a></li><li id="menu-item-56279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56279"><a href="https://www.nysportsday.com/author/leslie-treff/">Leslie Treff</a></li><li id="menu-item-56278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56278"><a href="https://www.nysportsday.com/author/admin/">Joe McDonald</a></li><li id="menu-item-60167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60167"><a href="https://www.nysportsday.com/author/esposito/">Andy Esposito</a></li><li id="menu-item-56275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56275"><a href="https://www.nysportsday.com/author/lloyd-carroll/">Lloyd Carroll</a></li><li id="menu-item-56276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56276"><a href="https://www.nysportsday.com/author/jeff-moeller/">Jeff Moeller</a></li><li id="menu-item-56274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56274"><a href="https://www.nysportsday.com/author/howie-karpin/">Howie Karpin</a></li><li id="menu-item-56277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56277"><a href="https://www.nysportsday.com/author/david-russell/">David Russell</a></li></ul></li><li id="menu-item-60742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60742"><a href="https://www.nysportsday.com/sports-betting/">Sports Betting</a><ul class="sub-menu"><li id="menu-item-56831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56831"><a href="https://www.nysportsday.com/online-casinos/">NY Online Casinos</a></li><li id="menu-item-56832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56832"><a href="https://www.nysportsday.com/nj/">NJ Online Gambling</a></li><li id="menu-item-61902" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61902"><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sports Betting Bonuses</a></li></ul></li></ul></div></nav><div class="search-toggle-wrap">
<ion-icon name="search"></ion-icon></div><div class="search-form-wrap"><form role="search" aria-label="Search for:" method="get" class="search-form" action="https://www.nysportsday.com">
<label for="search-form-1">
<input type="search" id="search-form-1" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<button type="submit" class="btn btn-primary search-submit" ><ion-icon name="search"></ion-icon></button></form></div></header><div id="primary" class="content-area"><main id="main" class="site-main"><article id="post-63738" class="post-63738 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-betting"><div class="hero mb-0 post-hero detached-image"><div class="bg"></div><div class="container"><div class="row justify-content-between"><div class="col-md-12"><div class="featured-category">
<a href="https://www.nysportsday.com/category/gambling/sports-betting/">
Sports Betting								</a></div><h1 class="interior-header">UFC 268 Betting Odds And Analysis — Usman Vs. Covington</h1><div class="post-meta"><div class="author"><div class="icon">
<ion-icon name="person-circle-outline"></ion-icon></div><div>
<span class="lbl">Written By:</span>
<a href="https://www.nysportsday.com/author/derrel-johnson/">
Derrel Johnson									</a></div></div><div class="dateblock published"><div class="icon">
<ion-icon name="newspaper-outline"></ion-icon></div><div>
<span class="lbl">Published:</span>
Nov 4, 2021</div></div><div class="dateblock updated"><div class="icon">
<ion-icon name="calendar-outline"></ion-icon></div><div>
<span class="lbl">Updated:</span>
Nov 4, 2021</div></div><div class="post-shares hide-mobile"><div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=UFC 268 Betting Odds And Analysis — Usman Vs. Covington&url=https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/&title=UFC 268 Betting Odds And Analysis — Usman Vs. Covington" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a></div></div></div></div></div></div><div class="entry-content"><div class="container"><div class="row"><div class="col-md-12"><div class="detached-image">
<img src="https://www.nysportsday.com/wp-content/uploads/UFC-announcer-1024x683.jpg" /></div><p>The UFC invades New York City&#8217;s Madison Square Garden again Saturday, Nov. 6. The fight card is highlighted by a pair of rematches in the main event and co-main of UFC 268.</p><p>Here’s all you need to know if you are looking to <a href="https://www.nysportsday.com/sports-betting/">lay down a bet</a> for either or both matches.</p><h2>Main Event: Kamaru Usman Vs. Colby Covington</h2><p>In their first matchup, UFC Welterweight champion Usman defeated Covington with a fifth-round finish by knockout nearly two years ago at UFC 245. Defying the odds, Usman has looked even better in 2021 with knockout finishes in February and April to retain his title and Performance of the Night honors for both.</p><p>Based on those dominant wins, Usman is a -310 favorite Saturday at <a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel</a> and a -320 favorite at <a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings</a>. Usman is as close to a sure-thing as you get these days in a UFC main event. He is starting to lap the division, as evidenced by his second victory over Jorge Masvidal in April.</p><p>If you are looking for a high-risk, high-reward bet, and you believe anything Covington is saying leading up to the fight (which is dangerous), then the +240 price on FanDuel and the +250 price on DraftKings just may whet your appetite.</p><p><strong>But I would expect another dominant performance by the champion.</strong></p><p><strong>Also Read:</strong> <a href="https://www.nysportsday.com/2021/11/03/new-yorkers-frequenting-connecticut-for-sports-betting-purposes/">New Yorkers frequenting Connecticut for sports betting purposes</a></p><h2>Co-Main Event: Rose Namajunas Vs. Zhang Weili</h2><p>Namajunas will defend her UFC Strawweight title against the woman she beat for the title seven months ago. Namajunas&#8217; first-round knockout of Weili shocked many. Though the champion had a decisive victory, FanDuel has Saturday&#8217;s rematch as a close one, with Namajunas at -106 and Weili at -114. At DraftKings, Namajunas is priced at  +105, while Weili is priced at -125.</p><p><strong>I would strongly suggest staying away from this fight</strong> unless you strongly believe the victory in April was a fluke, or you are certain that Namajunas is clearly better. Otherwise, the odds aren’t in your favor for this one.</p><p><strong>Also Read:</strong> <a href="https://www.nysportsday.com/2021/11/03/new-jersey-voters-uphold-in-state-college-sports-betting-ban/">New Jersey voters uphold in-state college sports betting ban</a></p><h2>Main Card Betting Odds</h2><p>Saturday&#8217;s main card will feature three other matches.</p><p>They are Justin Gaethje vs. Michael Chandler, Shane Burgos vs. Billy Quarantillo, and Marlon Vera vs. Frankie Edgar.</p><p>Here are the betting odds for all five bouts on the main card.</p><table id="tablepress-82" class="tablepress tablepress-id-82 tablepress-responsive"><thead><tr class="row-1 odd"><th class="column-1">Matchup (Favorite listed first)</th><th class="column-2">DraftKings</th><th class="column-3">FanDuel</th><th class="column-4">Caesars</th></tr></thead><tbody class="row-hover"><tr class="row-2 even"><td class="column-1">Kamaru Usman vs. Colby Covington</td><td class="column-2">-320/+250</td><td class="column-3">-310/+240</td><td class="column-4">-330/+260</td></tr><tr class="row-3 odd"><td class="column-1">Weili Zhang vs. Rose Namajunas</td><td class="column-2">-125/+105</td><td class="column-3">-122/+100</td><td class="column-4">-115/-105</td></tr><tr class="row-4 even"><td class="column-1">Marlon Vera vs. Frankie Edgar</td><td class="column-2">-170/+150</td><td class="column-3">-172/+140</td><td class="column-4">-175/+150</td></tr><tr class="row-5 odd"><td class="column-1">Shane Burgos vs. Billy Quarantillo</td><td class="column-2">-200/+170</td><td class="column-3">-200/+160</td><td class="column-4">-195/+165</td></tr><tr class="row-6 even"><td class="column-1">Justin Gaethje vs. Michael Chandler</td><td class="column-2">-210/+175</td><td class="column-3">-220/+176</td><td class="column-4">-200/+170</td></tr></tbody></table></div></div></div><div class="post-shares show-mobile"><div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=UFC 268 Betting Odds And Analysis — Usman Vs. Covington&url=https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2021/11/04/ufc-268-betting-odds-and-analysis-usman-vs-covington/&title=UFC 268 Betting Odds And Analysis — Usman Vs. Covington" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a></div><div class="container mt-4"><div class="row"><div class="col-md-12"><div class="author-box card"><h5 class="card-header">About the Author</h5><div class="card-body"><div class="info"><h3><a href="https://www.nysportsday.com/author/derrel-johnson/">Derrel Johnson</h3></a><div class="bio"></div></div></div></div></div></div></div></div></article></main></div><div class="social-row"><div class="container"><div class="row"><div class="col-md-4"><p>Get connected with us on Social Media</p></div><div class="col-md-8 socials">
<a href="https://www.facebook.com/nysportsday"><i class="dashicons dashicons-facebook-alt"></i></a><a href="https://twitter.com/nysportsday"><i class="dashicons dashicons-twitter"></i></a><a href="https://www.instagram.com/nysportsday/"><i class="dashicons dashicons-instagram"></i></a><a href="https://www.youtube.com/user/NYSportsDay"><i class="dashicons dashicons-googleplus"></i></a></div></div></div></div><footer class="footer-global"><div class="container"><div class="row"><div class="col-md-3"><h5>NY Sports Day</h5><p>NY Sports Day is an independent site that covers New York sports since 2004. We are fully credentialed by all nine major New York sports teams.</p></div><div class="col-md-3"><h5>NY Sports</h5><ul><li><a href="/yankees/">New York Yankees</a></li><li><a href="https://www.nysportsday.com/mets/">New York Mets</a></li><li><a href="https://www.nysportsday.com/giants/">New York Giants</a></li><li><a href="https://www.nysportsday.com/jets/">New York Jets</a></li></ul></div><p>&nbsp;</p><div class="col-md-3"><h5>NY Sports</h5><ul><li><a href="https://www.nysportsday.com/islanders/">New York Islanders</a></li><li><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li><li><a href="https://www.nysportsday.com/knicks/">New York Knicks</a></li><li><a href="https://www.nysportsday.com/nets/">Brooklyn Nets</a></li></ul></div><p>&nbsp;</p><div class="col-md-3"><h5>Sports Betting Pages</h5><ul><li><a href="https://www.nysportsday.com/sports-betting/">New York Sports Betting</a></li><li><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers NY </a></li><li><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY Bonus Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/draftkings/">Draftkings Sportsbook NY Promo Code</a></li></ul></div></div></div></footer><div class="footer-copyright">
Copyright © 2021 NYSportsDay - All rights reserved. <a href="https://www.nysportsday.com/about/">About </a> | <a href="https://www.nysportsday.com/contact/">Contact </a> | <a href="https://www.nysportsday.com/privacy-policy/">Privacy Policy</a> | <a href="https://www.nysportsday.com/responsible-gaming/">Responsible Gaming</a></div><div class="modal fade" id="gameModal" tabindex="-1" role="dialog" aria-labelledby="gameModalLabel" aria-hidden="true"><div class="modal-dialog modal-dialog-centered" role="document"><div class="modal-content"><div class="modal-header"><h5 class="modal-title" id="gameModalLabel">Modal title</h5>
<button type="button" class="close" data-dismiss="modal" aria-label="Close">
<span aria-hidden="true">&times;</span>
</button></div><div class="modal-body">
<iframe width="100%" height="550" src=""></iframe></div></div></div></div> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/a39eef2b6e8c2e244829b67a5a3a2cc6.js?ver=7e8d4' id='regenerator-runtime-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/d4998cb41d67d730b95df1a2fd5fa348.js?ver=f46f5' id='wp-polyfill-js'></script> <script type='text/javascript' id='contact-form-7-js-extra'>/*  */
var wpcf7 = {"api":{"root":"https:\/\/www.nysportsday.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/c3647deab36393f7518d164ba5911d47.js?ver=bc06c' id='contact-form-7-js'></script> <script type='text/javascript' id='ta_main_js-js-extra'>/*  */
var thirsty_global_vars = {"home_url":"\/\/www.nysportsday.com","ajax_url":"https:\/\/www.nysportsday.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"visit","link_prefixes":["recommends","visit"],"post_id":"63738","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/ce961e5692c311e29b501357440157b0.js?ver=f15b9' id='ta_main_js-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/aa66b29fa0a299739181b3d258f4608f.js?ver=85146' id='bootstrap-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/f95bd4f5fea43fbce913065137f79d20.js?ver=160b0' id='globaljs-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/c9f15b058abc689e6d073cc54112029b.js?ver=f80b5' id='tablepress-datatables-js'></script> <script type="text/javascript">jQuery(function($){
$('#tablepress-82').dataTable({"order":[],"orderClasses":false,"stripeClasses":["even","odd"],"pagingType":"simple"});
});</script> </body></html>
<!-- Page optimized by LiteSpeed Cache @2021-11-04 18:07:42 -->
<!-- Page generated by LiteSpeed Cache 4.4.3 on 2021-11-04 14:07:42 -->