<!doctype html>
<html lang="en-US">
<head>
<!-- Google Tag Manager -->
<script>
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&amp;l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK2SCV9');
</script>
<!-- End Google Tag Manager --><meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&#038;display=swap" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" rel="preload">
<script type="module" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.esm.js" defer></script>
<script nomodule="" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.js" defer></script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.4 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Islanders In Familiar Territory As They Turn The Page To Game Four - NY Sports Day</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://www.nysportsday.com/wp-content/cache/min/1/c173b7950e81ecf8234d2f768d01a5d4.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />
	<link rel="canonical" href="https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Islanders In Familiar Territory As They Turn The Page To Game Four - NY Sports Day" />
	<meta property="og:description" content="When you look at what the Islanders over the last three years in the Lou [&hellip;]" />
	<meta property="og:url" content="https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/" />
	<meta property="og:site_name" content="NY Sports Day" />
	<meta property="article:published_time" content="2021-06-04T14:19:52+00:00" />
	<meta property="og:image" content="https://www.nysportsday.com/wp-content/uploads/dlv210603014_bos_v_nyi.jpg" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="667" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Peter Schwartz" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.nysportsday.com/#website","url":"https://www.nysportsday.com/","name":"NY Sports Day","description":"Your Gotham Sports News Source","potentialAction":[{"@type":"SearchAction","target":"https://www.nysportsday.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/#primaryimage","inLanguage":"en-US","url":"https://www.nysportsday.com/wp-content/uploads/dlv210603014_bos_v_nyi.jpg","contentUrl":"https://www.nysportsday.com/wp-content/uploads/dlv210603014_bos_v_nyi.jpg","width":1000,"height":667,"caption":"UNIONDALE, NY - JUNE 03: New York Islanders Center Mathew Barzal (13) skates with the puck with Boston Bruins Defenseman Mike Reilly (6) in pursuit during the first period of Game 3 of the NHL Stanley Cup Playoffs Second Round between the Boston Bruins and the New York Islanders on June 3, 2021, at the Nassau Veterans Memorial Coliseum in Uniondale, NY. (Photo by Gregory Fisher/Icon Sportswire)"},{"@type":"WebPage","@id":"https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/#webpage","url":"https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/","name":"Islanders In Familiar Territory As They Turn The Page To Game Four - NY Sports Day","isPartOf":{"@id":"https://www.nysportsday.com/#website"},"primaryImageOfPage":{"@id":"https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/#primaryimage"},"datePublished":"2021-06-04T14:19:52+00:00","dateModified":"2021-06-04T14:19:52+00:00","author":{"@id":"https://www.nysportsday.com/#/schema/person/71cc1a2589b984bf6268b028c2125d34"},"breadcrumb":{"@id":"https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/"]}]},{"@type":"BreadcrumbList","@id":"https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.nysportsday.com/","url":"https://www.nysportsday.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.nysportsday.com/news/","url":"https://www.nysportsday.com/news/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/#webpage"}}]},{"@type":"Person","@id":"https://www.nysportsday.com/#/schema/person/71cc1a2589b984bf6268b028c2125d34","name":"Peter Schwartz","image":{"@type":"ImageObject","@id":"https://www.nysportsday.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ce3b9490c1a6bb7f8acf77b7871ed35a?s=96&d=retro&r=g","contentUrl":"https://secure.gravatar.com/avatar/ce3b9490c1a6bb7f8acf77b7871ed35a?s=96&d=retro&r=g","caption":"Peter Schwartz"},"description":"Peter covers the Islanders for New York Sports Day while also writing about general sports in the New York/New Jersey area. In addition to his column, Peter also hosts his \u201cSchwartz On Sports\u201d podcast as he interviews players, coaches, and other sports personalities. He is also currently a sports anchor for WFAN Radio, CBS Sports Radio and WCBS 880 radio while also serving as the public address announcer for the New York Cosmos soccer club. Peter spent 8 years as the radio play by play voice for the New York Dragons of the Arena Football League. He was also the radio play by play announcer for the XFL\u2019s NY/NJ Hitmen in 2001 and the radio play by play announcer for the New York Saints of the Major Indoor Lacrosse League from 1993 to 1996.","url":"https://www.nysportsday.com/author/peter-schwartz/"}]}</script>
	<!-- / Yoast SEO plugin. -->









<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.nysportsday.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>


<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.nysportsday.com/feed/podcast" />

<link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-270x270.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>

<body class="post-template-default single single-post postid-61903 single-format-standard">

	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PK2SCV9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<header class="site-header">

				<div class="mega-menu">
		<div class="logo-col"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" /></noscript></div>
<div class="container">
<div class="row">
<div class="col-md-6">
<h4 class="mm-nav-label">NY Baseball &amp; Football</h4>
<ul>
<li><a href="/yankees/">New York Yankees</a></li>
<li><a href="https://www.nysportsday.com/category/baseball/new-york-mets/">New York Mets</a></li>
<li><a href="https://www.nysportsday.com/category/football/new-york-giants/">New York Giants</a></li>
<li><a href="https://www.nysportsday.com/category/football/new-york-jets/">New York Jets</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">NY Hockey &amp; Basketball</h4>
<ul>
<li><a href="https://www.nysportsday.com/category/hockey/new-york-islanders/">New York Islanders</a></li>
<li><a href="https://www.nysportsday.com/category/hockey/new-york-rangers/">New York Rangers</a></li>
<li><a href="https://www.nysportsday.com/category/basketball/new-york-knicks/">New York Knicks</a></li>
<li><a href="https://www.nysportsday.com/category/basketball/new-jersey-nets/">New Jersey Nets</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">Other</h4>
<ul>
<li><a href="https://www.nysportsday.com/new-york-sports-betting/">New York Sports Betting</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">Contact</h4>
<ul>
<li><a href="https://www.nysportsday.com/about/">About</a></li>
<li><a href="https://www.nysportsday.com/contact-us/">Contact</a></li>
</ul>
</div>
</div>
</div>
		</div>
		
	
		<div class="mega-menu-toggle">
			<div class="menu">
				<div class="bar"></div>
				<div class="bar"></div>
				<div class="bar"> </div>
			</div>
		</div>


	
		<div class="site-branding">
			<a href="https://www.nysportsday.com/" rel="home">
				<span class="logo-m"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="nysportsday.com" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png"/><noscript><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" alt="nysportsday.com"/></noscript></span>
			</a>
		</div>	

		<nav id="site-navigation" class="main-navigation">
			<div class="menu-menu-container"><ul id="primary-menu-left" class="menu"><li id="menu-item-15689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-15689"><a href="https://www.nysportsday.com/">Home</a></li>
<li id="menu-item-15690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15690"><a href="https://www.nysportsday.com/category/baseball/">Baseball</a>
<ul class="sub-menu">
	<li id="menu-item-56865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56865"><a href="https://www.nysportsday.com/yankees/">NY Yankees</a></li>
	<li id="menu-item-56864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56864"><a href="https://www.nysportsday.com/mets/">NY Mets</a></li>
</ul>
</li>
<li id="menu-item-15693" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15693"><a href="https://www.nysportsday.com/category/football/">Football</a>
<ul class="sub-menu">
	<li id="menu-item-56862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56862"><a href="https://www.nysportsday.com/jets/">NY Jets News</a></li>
	<li id="menu-item-56863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56863"><a href="https://www.nysportsday.com/giants/">NY Giants</a></li>
</ul>
</li>
<li id="menu-item-15696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15696"><a href="https://www.nysportsday.com/category/basketball/">Basketball</a>
<ul class="sub-menu">
	<li id="menu-item-56860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56860"><a href="https://www.nysportsday.com/nets/">Brooklyn Nets</a></li>
	<li id="menu-item-56861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56861"><a href="https://www.nysportsday.com/knicks/">NY Knicks</a></li>
</ul>
</li>
<li id="menu-item-15699" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-15699"><a href="https://www.nysportsday.com/category/hockey/">Hockey</a>
<ul class="sub-menu">
	<li id="menu-item-56858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56858"><a href="https://www.nysportsday.com/islanders/">NY Islanders</a></li>
	<li id="menu-item-56859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56859"><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li>
	<li id="menu-item-56857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56857"><a href="https://www.nysportsday.com/devils/">NJ Devils</a></li>
</ul>
</li>
<li id="menu-item-15711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15711"><a href="https://www.nysportsday.com/category/other-sports/">Other</a>
<ul class="sub-menu">
	<li id="menu-item-15718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15718"><a href="https://www.nysportsday.com/category/tennis/us-open-tennis/">US Open Tennis</a></li>
	<li id="menu-item-15712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15712"><a href="https://www.nysportsday.com/category/boxing/">Boxing</a></li>
	<li id="menu-item-15713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15713"><a href="https://www.nysportsday.com/category/golf/">Golf</a></li>
	<li id="menu-item-15714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15714"><a href="https://www.nysportsday.com/category/soccer/new-york-cosmos/">New York Cosmos</a></li>
	<li id="menu-item-15715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15715"><a href="https://www.nysportsday.com/category/soccer/new-york-red-bulls/">New York Red Bulls</a></li>
	<li id="menu-item-16038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16038"><a href="https://www.nysportsday.com/category/soccer/nycfc/">NYC FC</a></li>
	<li id="menu-item-15729" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15729"><a href="https://www.nysportsday.com/category/college/college-basketball/">College Basketball</a></li>
	<li id="menu-item-15730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15730"><a href="https://www.nysportsday.com/category/college/college-football/">College Football</a></li>
</ul>
</li>
<li id="menu-item-56830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56830"><a href="#">Columnists</a>
<ul class="sub-menu">
	<li id="menu-item-56273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56273"><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</a></li>
	<li id="menu-item-56272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56272"><a href="https://www.nysportsday.com/author/hal-bock/">Hal Bock</a></li>
	<li id="menu-item-56279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56279"><a href="https://www.nysportsday.com/author/leslie-treff/">Leslie Treff</a></li>
	<li id="menu-item-56278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56278"><a href="https://www.nysportsday.com/author/admin/">Joe McDonald</a></li>
	<li id="menu-item-60167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60167"><a href="https://www.nysportsday.com/author/esposito/">Andy Esposito</a></li>
	<li id="menu-item-56275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56275"><a href="https://www.nysportsday.com/author/lloyd-carroll/">Lloyd Carroll</a></li>
	<li id="menu-item-56276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56276"><a href="https://www.nysportsday.com/author/jeff-moeller/">Jeff Moeller</a></li>
	<li id="menu-item-56274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56274"><a href="https://www.nysportsday.com/author/howie-karpin/">Howie Karpin</a></li>
	<li id="menu-item-56277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56277"><a href="https://www.nysportsday.com/author/david-russell/">David Russell</a></li>
</ul>
</li>
<li id="menu-item-60742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60742"><a href="https://www.nysportsday.com/sports-betting/">Sports Betting</a>
<ul class="sub-menu">
	<li id="menu-item-56831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56831"><a href="https://www.nysportsday.com/online-casinos/">NY Online Casinos</a></li>
	<li id="menu-item-56832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56832"><a href="https://www.nysportsday.com/nj/">NJ Online Gambling</a></li>
	<li id="menu-item-61901" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61901"><a href="https://www.nysportsday.com/sports-betting/apps/">NY Sports Betting Apps</a></li>
	<li id="menu-item-61902" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61902"><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sports Betting Bonuses</a></li>
</ul>
</li>
<li id="menu-item-15723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15723"><a href="https://www.nysportsday.com/themofo2">Forum</a></li>
</ul></div>		</nav> 

		<div class="search-toggle-wrap">
			<ion-icon name="search"></ion-icon>
		</div>

		<div class="search-form-wrap">
			<form role="search" aria-label="Search for:" method="get" class="search-form" action="https://www.nysportsday.com">
				<label for="search-form-1">
					<input type="search" id="search-form-1" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<button type="submit" class="btn btn-primary search-submit" ><ion-icon name="search"></ion-icon></button>
			</form>
		</div>


	</header>









	<div id="primary" class="content-area">
		<main id="main" class="site-main">

		<article id="post-61903" class="post-61903 post type-post status-publish format-standard has-post-thumbnail hentry category-hockey category-new-york-islanders tag-featured-article">

		
	
	<!-- All posts and pages with custom header -->		
		<div class="hero mb-0 post-hero detached-image">
				<div class="bg"></div>
					<div class="container">
				<div class="row justify-content-between">
					<div class="col-md-12">
													<div class="featured-category">
								<a href="https://www.nysportsday.com/category/hockey/new-york-islanders/">
									New York Islanders								</a>
													</div>
						<h1 class="interior-header">Islanders In Familiar Territory As They Turn The Page To Game Four</h1>
						<div class="post-meta">
														<div class="author">
																<div data-bg="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" class="icon rocket-lazyload" style=""></div>
																<div>
									<span class="lbl">Written By:</span>
									<a href="https://www.nysportsday.com/author/peter-schwartz/">
										Peter Schwartz									</a>
								</div>
							</div>
																												<div class="dateblock published">
								<div class="icon">
									<ion-icon name="newspaper-outline"></ion-icon>
								</div>
								<div>
									<span class="lbl">Published:</span>
									Jun 4, 2021								</div>
							</div>
														<div class="dateblock updated">
								<div class="icon">
									<ion-icon name="calendar-outline"></ion-icon>
								</div>
								<div>
									<span class="lbl">Updated:</span>
									Jun 4, 2021								</div>
							</div>	
										
										
								<div class="post-shares hide-mobile">
									<div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
									<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
									<a href="http://twitter.com/share?text=Islanders In Familiar Territory As They Turn The Page To Game Four&url=https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
									<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/&title=Islanders In Familiar Territory As They Turn The Page To Game Four" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a>
								</div>
													</div>
					</div>			
				</div>
			</div>
		</div>


	<!-- All other pages -->
	



	<div class="entry-content">
		<div class="container">
			<div class="row">
				<div class="col-md-12">

								<div class="detached-image">
					<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/dlv210603014_bos_v_nyi.jpg" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/dlv210603014_bos_v_nyi.jpg" /></noscript>
											<div class="photo-credit">
							Gregory Fisher/Icon Sportswire 						</div>
									</div>
				
				<p>When you look at what the Islanders over the last three years in the Lou Lamoriello/Barry Trotz era, they’ve certainly developed a very important ability…they generally are able to bounce when they face some adversity.  They are now in a position where they have to do it again as they trail the Boston Bruins two games to one heading into game four of their second round series on Saturday night at Nassau Coliseum (715pm NBC).</p>
<p>It’s been a tough series to this point and now the Islanders are faced with the same situation that they faced in the opening round against the Penguins.</p>
<p>“Both teams are playing hard,” said Islanders forward Mat Barzal who scored the only goal in the Islanders’ 2-1 overtime loss in game three.  “It’s tough for about ten minutes. It’s the playoffs so you turn the page.  We’re excited.  We’ve been in this situation before against (Pittsburgh).  We’re just going to grind.”</p>
<figure id="attachment_61908" aria-describedby="caption-attachment-61908" style="width: 443px" class="wp-caption aligncenter"><a href="https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi.jpg"><img class=" wp-image-61908" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20443%20295'%3E%3C/svg%3E" alt="" width="443" height="295" data-lazy-srcset="https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi-300x200.jpg 300w, https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi-768x512.jpg 768w, https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi.jpg 1000w" data-lazy-sizes="(max-width: 443px) 100vw, 443px" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi-300x200.jpg" /><noscript><img class=" wp-image-61908" src="https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi-300x200.jpg" alt="" width="443" height="295" srcset="https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi-300x200.jpg 300w, https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi-768x512.jpg 768w, https://www.nysportsday.com/wp-content/uploads/dlv210603022_bos_v_nyi.jpg 1000w" sizes="(max-width: 443px) 100vw, 443px" /></noscript></a><figcaption id="caption-attachment-61908" class="wp-caption-text">UNIONDALE, NY &#8211; JUNE 03: New York Islanders Center Mathew Barzal (13) skates past the bench and is congratulated by teammates for scoring a goal during the third period of Game 3 of the NHL Stanley Cup Playoffs Second Round between the Boston Bruins and the New York Islanders on June 3, 2021, at the Nassau Veterans Memorial Coliseum in Uniondale, NY. (Photo by Gregory Fisher/Icon Sportswire)</figcaption></figure>
<p>In the opening round, the Islanders dropped game three at home to the Penguins but then reeled off three straight wins to capture the series and move on.  They grabbled some momentum and temporarily seized home-ice advantage with a 4-3 overtime win in game two up in Boston.   But now the pendulum has swung back towards the Bruins after the Islanders failed to capitalize on some scoring chances in game three, especially in overtime.</p>
<p><em>Islanders vs Bruins (Boston leads 2-1)</em></p>
<p><em>Game 1…Saturday May 29<sup>th</sup>…Bruins 5 Islanders 2…</em></p>
<p><em>Game 2…Monday May 31<sup>st</sup>…Islanders 4 Bruins 3 (OT)…</em></p>
<p><em>Game 3…Thursday June 3<sup>rd</sup>…Bruins 3 Islanders 1 (OT)…</em></p>
<p><em>Game 4…Saturday June 5<sup>th</sup>…Bruins at Islanders…715pm NBC</em></p>
<p><em>Game 5…Monday June 7<sup>th</sup>…Islanders at Bruins…630pm NBCSN</em></p>
<p><em>*Game 6…Wednesday June 9<sup>th</sup>…Bruins at Islanders…TBD</em></p>
<p><em>*Game 7…Friday June 11<sup>th</sup>…Islanders at Bruins…TBD</em></p>
<p><em>*If Necessary</em></p>
<p><em> </em>“These are two teams that are…let’s just say what it is…that we’re fairly evenly matched,” said Islanders Head Coach Barry Trotz.  “We’re playing nose-to-nose blue collar hockey and it’s not going to be easy. The hard way is going to be the only way in this series.”</p>
<figure id="attachment_61909" aria-describedby="caption-attachment-61909" style="width: 441px" class="wp-caption aligncenter"><a href="https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi.jpg"><img class=" wp-image-61909" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20441%20294'%3E%3C/svg%3E" alt="" width="441" height="294" data-lazy-srcset="https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi-300x200.jpg 300w, https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi-768x512.jpg 768w, https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi.jpg 1000w" data-lazy-sizes="(max-width: 441px) 100vw, 441px" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi-300x200.jpg" /><noscript><img class=" wp-image-61909" src="https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi-300x200.jpg" alt="" width="441" height="294" srcset="https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi-300x200.jpg 300w, https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi-768x512.jpg 768w, https://www.nysportsday.com/wp-content/uploads/dlv210603004_bos_v_nyi.jpg 1000w" sizes="(max-width: 441px) 100vw, 441px" /></noscript></a><figcaption id="caption-attachment-61909" class="wp-caption-text">UNIONDALE, NY &#8211; JUNE 03: New York Islanders Defenseman Ryan Pulock (6) takes a shot on goal during the first period of Game 3 of the NHL Stanley Cup Playoffs Second Round between the Boston Bruins and the New York Islanders on June 3, 2021, at the Nassau Veterans Memorial Coliseum in Uniondale, NY. (Photo by Gregory Fisher/Icon Sportswire)</figcaption></figure>
<p>“We’re in a series here,” said Islanders defenseman Ryan Pulock.  “We have a big game on Saturday.  We’re going to regroup here and get ready for that.”</p>
<p>In last season’s playoffs, the Islanders faced adversity in the second round when they led the Philadelphia Flyers three games to one but then lost games five and six in overtime before bouncing back to win game seven.  In the Eastern Conference Final, the Islanders were blown out in game one and then lost game two on a goal in the final seconds of regulation.  They came back to win game three and then won a game five in overtime to extend the series.</p>
<p>And then in this year’s playoffs, the Islanders have shown the ability to shake off some disappointment and come back with better results.  When it comes to recovering from adversity, the Islanders have been there and done that on multiple occasions.</p>
<figure id="attachment_61904" aria-describedby="caption-attachment-61904" style="width: 461px" class="wp-caption aligncenter"><a href="https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi.jpg"><img class=" wp-image-61904" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20461%20307'%3E%3C/svg%3E" alt="" width="461" height="307" data-lazy-srcset="https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi-300x200.jpg 300w, https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi-768x512.jpg 768w, https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi.jpg 1000w" data-lazy-sizes="(max-width: 461px) 100vw, 461px" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi-300x200.jpg" /><noscript><img class=" wp-image-61904" src="https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi-300x200.jpg" alt="" width="461" height="307" srcset="https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi-300x200.jpg 300w, https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi-768x512.jpg 768w, https://www.nysportsday.com/wp-content/uploads/dlv210603015_bos_v_nyi.jpg 1000w" sizes="(max-width: 461px) 100vw, 461px" /></noscript></a><figcaption id="caption-attachment-61904" class="wp-caption-text">UNIONDALE, NY &#8211; JUNE 03: New York Islanders Center Jean-Gabriel Pageau (44) checks Boston Bruins Left Wing Taylor Hall (71) during the first period of Game 3 of the NHL Stanley Cup Playoffs Second Round between the Boston Bruins and the New York Islanders on June 3, 2021, at the Nassau Veterans Memorial Coliseum in Uniondale, NY. (Photo by Gregory Fisher/Icon Sportswire)</figcaption></figure>
<p>“We just gotta bounce back,” said Islanders forward Jean-Gabriel Pageau.  “I’m not too worried with the character that is there is in this room.  I’m very positive and I’m very excited for the next game at home.  I think we’re going to bounce back and the know the guys are hungry for a win.”</p>
<p>“There’s no panic,” said Trotz.  “We were in the same situation before.  We look forward.  We don’t look back.  We’ll try to correct a couple of things, reset and go at it   We’ll just need our best effort from everybody again.”</p>
<p>And that includes the sellout crowd of 12,000 that rocked “The Barn” for game three but didn’t get a chance to explode as often as they would have liked.  They’ll now reload, just like they did between games three and four against the Penguins, and hope they get to roar a little bit more and belt out some more “YES YES YES” chants.  The Islanders will need a better start to help make that happen and they also need to recapture the power play magic that they had in game two.</p>
<p>Based on what we’ve seen in the first three games, this figures to be a series that could go the distance with lots of twists and turns.</p>
				</div>
			</div>
		</div>

		<div class="post-shares show-mobile">
			<div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
			<a href="http://twitter.com/share?text=Islanders In Familiar Territory As They Turn The Page To Game Four&url=https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
			<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2021/06/04/islanders-in-familiar-territory-as-they-turn-the-page-to-game-four/&title=Islanders In Familiar Territory As They Turn The Page To Game Four" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a>
		</div>
		
				
	<div class="container mt-4">
		<div class="row">
			<div class="col-md-12">
				<div class="author-box card">
					<h5 class="card-header">About the Author</h5>	
					<div class="card-body">
												<div class="avatar pr-3">
							<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" /></noscript>
						</div>	
												<div class="info">					
							<h3><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</h3></a>
							<div class="bio">
								Peter covers the Islanders for New York Sports Day while also writing about general sports in the New York/New Jersey area.  In addition to his column, Peter also hosts his “Schwartz On Sports” podcast as he interviews players, coaches, and other sports personalities. He is also currently a sports anchor for WFAN Radio, CBS Sports Radio and WCBS 880 radio while also serving as the public address announcer for the New York Cosmos soccer club.  Peter spent 8 years as the radio play by play voice for the New York Dragons of the Arena Football League. He was also the radio play by play announcer for the XFL’s NY/NJ Hitmen in 2001 and the radio play by play announcer for the New York Saints of the Major Indoor Lacrosse League from 1993 to 1996.							</div>
						</div>
					</div>
				</div>					
			</div>
		</div>
	</div>




	</div>

</article>
		</main><!-- #main -->
	</div><!-- #primary -->

<div class="social-row">
  <div class="container">
      <div class="row">
        <div class="col-md-4">
          <p>Get connected with us on Social Media</p>
        </div>
        <div class="col-md-8 socials">
           <a href="https://www.facebook.com/nysportsday"><i class="dashicons dashicons-facebook-alt"></i></a><a href="https://twitter.com/nysportsday"><i class="dashicons dashicons-twitter"></i></a><a href="https://www.instagram.com/nysportsday/"><i class="dashicons dashicons-instagram"></i></a><a href="https://www.youtube.com/user/NYSportsDay"><i class="dashicons dashicons-googleplus"></i></a>
        </div>
      </div>
    </div>
</div>
<footer class="footer-global">
	<div class="container">
		<div class="row">
			<div class="col-md-3">
<h5>NY Sports Day</h5>
<p>NY Sports Day is an independent site that covers New York sports since 2004. We are fully credentialed by all nine major New York sports teams.</p>
</div>
<div class="col-md-3">
<h5>NY Sports</h5>
<ul>
<li><a href="/yankees/">New York Yankees</a></li>
<li><a href="https://www.nysportsday.com/mets/">New York Mets</a></li>
<li><a href="https://www.nysportsday.com/giants/">New York Giants</a></li>
<li><a href="https://www.nysportsday.com/jets/">New York Jets</a></li>
</ul>
</div>
<div class="col-md-3">
<h5>NY Sports</h5>
<ul>
<li><a href="https://www.nysportsday.com/islanders/">New York Islanders</a></li>
<li><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li>
<li><a href="https://www.nysportsday.com/knicks/">New York Knicks</a></li>
<li><a href="https://www.nysportsday.com/nets/">New Jersey Nets</a></li>
</ul>
</div>
<div class="col-md-3">
<h5>Sports Betting Pages</h5>
<ul>
<li><a href="https://www.nysportsday.com/sports-betting/">New York Sports Betting</a></li>
<li><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers NY </a></li>
<li><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY Bonus Code</a></li>
<li><a href="https://www.nysportsday.com/sports-betting/draftkings/">Draftkings Sportsbook NY Promo Code</a></li>
</ul>
</div>
		</div>
	</div>
</footer>

<div class="footer-copyright">
Copyright © 2021 NYSportsDay - All rights reserved. <a href="https://www.nysportsday.com/about/">About </a> | <a href="https://www.nysportsday.com/contact/">Contact </a> | <a href="https://www.nysportsday.com/privacy-policy/">Privacy Policy</a> | <a href="https://www.nysportsday.com/responsible-gaming/">Responsible Gaming</a> 

</div>

<div class="modal fade" id="gameModal" tabindex="-1" role="dialog" aria-labelledby="gameModalLabel" aria-hidden="true">
  <div class="modal-dialog modal-dialog-centered" role="document">
    <div class="modal-content">
      <div class="modal-header">
        <h5 class="modal-title" id="gameModalLabel">Modal title</h5>
        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
          <span aria-hidden="true">&times;</span>
        </button>
      </div>
      <div class="modal-body">
       <iframe width="100%" height="550" src=""></iframe>
      </div>
    </div>
  </div>
</div>

<script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>



<script type='text/javascript' id='ta_main_js-js-extra'>
/* <![CDATA[ */
var thirsty_global_vars = {"home_url":"\/\/www.nysportsday.com","ajax_url":"https:\/\/www.nysportsday.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"visit","link_prefixes":["recommends","visit"],"post_id":"61903","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/* ]]> */
</script>

<script type='text/javascript' src='https://code.jquery.com/jquery-3.1.0.js?ver=20151215' id='jqueryslim-js'></script>


<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.nysportsday.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><script src="https://www.nysportsday.com/wp-content/cache/min/1/488675d0f193939be85ec844ccc4c22e.js" data-minify="1" defer></script><noscript><link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&#038;display=swap" rel="stylesheet"><link rel="stylesheet" href="https://www.nysportsday.com/wp-content/cache/min/1/c173b7950e81ecf8234d2f768d01a5d4.css" media="all" data-minify="1" /></noscript></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1622816392 -->