<!doctype html><html lang="en-US"><head>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK2SCV9');</script> <meta charset="UTF-8"><link data-optimized="2" rel="stylesheet" href="https://www.nysportsday.com/wp-content/litespeed/css/472885b93da761c62fd93fa45fc7933c.css?ver=37119" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="profile" href="https://gmpg.org/xfn/11"><link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&display=swap" rel="stylesheet"> <script type="module" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.esm.js"></script> <script nomodule="" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.js"></script> <link rel="preconnect" href="https://us1.catenaus.com/" crossorigin><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <script>window.dataLayer = window.dataLayer || [];
                window.dataLayer.push({
category: `New York Mets,Sports Betting`,
tags: `regions:NY;content-provider:metabet;`,
event: `Page Data`,
regionName: ``,
pageTemplate: ``
});</script> <title>New York Mets World Series Odds 2022</title><meta name="description" content="Get the Mets world series odds and your best bets for the NY Mets to win the NL Pennant, regular season wins, and their next matchup." /><link rel="canonical" href="https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="New York Mets World Series Odds 2022" /><meta property="og:description" content="Get the Mets world series odds and your best bets for the NY Mets to win the NL Pennant, regular season wins, and their next matchup." /><meta property="og:url" content="https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/" /><meta property="og:site_name" content="NY Sports Day" /><meta property="article:published_time" content="2022-07-11T04:45:51+00:00" /><meta property="article:modified_time" content="2022-07-11T15:30:07+00:00" /><meta property="og:image" content="https://www.nysportsday.com/wp-content/uploads/NY-Mets6-scaled.jpg" /><meta property="og:image:width" content="2560" /><meta property="og:image:height" content="1707" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Hannah Vanbiber" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Hannah Vanbiber" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="2 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.nysportsday.com/#website","url":"https://www.nysportsday.com/","name":"NY Sports Day","description":"Your Gotham Sports News Source","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.nysportsday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#primaryimage","url":"https://www.nysportsday.com/wp-content/uploads/NY-Mets6-scaled.jpg","contentUrl":"https://www.nysportsday.com/wp-content/uploads/NY-Mets6-scaled.jpg","width":2560,"height":1707,"caption":"New York Mets catcher Tomas Nido (3) celebrates with right fielder Starling Marte, right, after closing the ninth inning of a baseball game against the Washington Nationals, Wednesday, June 1, 2022, in New York. (AP Photo/John Minchillo)"},{"@type":"WebPage","@id":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#webpage","url":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/","name":"New York Mets World Series Odds 2022","isPartOf":{"@id":"https://www.nysportsday.com/#website"},"primaryImageOfPage":{"@id":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#primaryimage"},"datePublished":"2022-07-11T04:45:51+00:00","dateModified":"2022-07-11T15:30:07+00:00","author":{"@id":"https://www.nysportsday.com/#/schema/person/4ed4a6a07db2262983c596093b39e80f"},"description":"Get the Mets world series odds and your best bets for the NY Mets to win the NL Pennant, regular season wins, and their next matchup.","breadcrumb":{"@id":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#breadcrumb"},"inLanguage":"en-US","potentialAction":{"@type":"ListenAction","target":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#podcast_player_71300","object":{"@id":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#/schema/podcast"}},"mainEntityOfPage":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#/schema/podcast"},{"@type":"BreadcrumbList","@id":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.nysportsday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.nysportsday.com/news/"},{"@type":"ListItem","position":3,"name":"New York Mets World Series Odds 2022"}]},{"@type":"Person","@id":"https://www.nysportsday.com/#/schema/person/4ed4a6a07db2262983c596093b39e80f","name":"Hannah Vanbiber","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.nysportsday.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/9ed2b18e0b47c8a46e7365360edac2f8?s=96&d=retro&r=g","contentUrl":"https://secure.gravatar.com/avatar/9ed2b18e0b47c8a46e7365360edac2f8?s=96&d=retro&r=g","caption":"Hannah Vanbiber"},"description":"Hannah Vanbiber is an LSU fan by birth, Cavaliers fan by marriage, and Mets fan by choice. She started her journalism career in Chattanooga, Tennessee, as a reporter covering local sports, entertainment, and business in the East Tennessee area. She was the leading editor for the launch of a new sports magazine brand by Chattanooga’s CityScope Magazine. Hannah moved to New York City in 2013 and started writing freelance for several clients including newspapers, magazines, and corporate brands. She also joined the nonprofit world and spent eight years working in fundraising, most recently as the Director of Volunteers at New York City’s oldest homeless services organization. She is now a full-time freelance writer, editor, and reporter, covering women’s sports and sports betting in the New York metropolitan area. Hannah lives in Manhattan with her husband, Ben Wagner, whose loyalty to LeBron James knows no bounds.","url":"https://www.nysportsday.com/author/hannah-vanbiber/"},{"@type":["PodcastEpisode","OnDemandEvent"],"@id":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#/schema/podcast","eventAttendanceMode":"https://schema.org/OnlineEventAttendanceMode","location":{"@type":"VirtualLocation","url":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/","@id":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/#webpage"},"url":"https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/","name":"New York Mets World Series Odds 2022","datePublished":"2022-07-11","description":"The New York Mets are second in the National League, but after building a big [&hellip;]"}]}</script> <style id='global-styles-inline-css' type='text/css'>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</style> <script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/073b0eb07bc32242cbdf38c34712e4b2.js?ver=97ee0' id='jquery-migrate-js'></script> <link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.nysportsday.com/feed/podcast" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-180x180.png" /><meta name="msapplication-TileImage" content="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-270x270.png" /><style>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</style></head><body class="post-template-default single single-post postid-71300 single-format-standard">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PK2SCV9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><header class="site-header"><div class="bonus-mega-menu mega-menu"><ul id="menu-mega-menu" class="bonus-mega-menu-list mega-menu-list"><li id="menu-item-69904" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69904 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>What&#8217;s Popular</a><ul class="sub-menu"><li id="menu-item-69900" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69900 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/">New York Sports Betting</a></li><li id="menu-item-69901" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69901 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sportsbook Bonuses</a></li><li id="menu-item-71521" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71521 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/">Best NY Sports Odds</a></li><li id="menu-item-70304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70304 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/parlay/">Compare Parlay Odds</a></li></ul></li><li id="menu-item-69887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69887 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>NY Baseball &#038; Football</a><ul class="sub-menu"><li id="menu-item-69888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69888 bonus-mega-menu-item"><a href="https://www.nysportsday.com/yankees/">New York Yankees</a></li><li id="menu-item-69889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69889 bonus-mega-menu-item"><a href="https://www.nysportsday.com/mets/">New York Mets</a></li><li id="menu-item-69890" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69890 bonus-mega-menu-item"><a href="https://www.nysportsday.com/giants/">New York Giants</a></li><li id="menu-item-69891" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69891 bonus-mega-menu-item"><a href="https://www.nysportsday.com/jets/">New York Jets</a></li></ul></li><li id="menu-item-69892" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69892 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>NY Hockey &#038; Basketball</a><ul class="sub-menu"><li id="menu-item-69893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69893 bonus-mega-menu-item"><a href="https://www.nysportsday.com/islanders/">New York Islanders</a></li><li id="menu-item-69894" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69894 bonus-mega-menu-item"><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li><li id="menu-item-69895" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69895 bonus-mega-menu-item"><a href="https://www.nysportsday.com/knicks/">New York Knicks</a></li><li id="menu-item-69896" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69896 bonus-mega-menu-item"><a href="https://www.nysportsday.com/nets/">Brooklyn Nets</a></li></ul></li><li id="menu-item-69897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69897 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>Sportsbook Reviews</a><ul class="sub-menu"><li id="menu-item-70023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70023 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars Sportsbook NY</a></li><li id="menu-item-71519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71519 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel Sportsbook NY</a></li><li id="menu-item-71520" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71520 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/pointsbet/">PointsBet New York</a></li><li id="menu-item-71707" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71707 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers New York</a></li></ul></li></ul></div><div class="mega-menu-toggle"><div class="menu"><div class="bar"></div><div class="bar"></div><div class="bar"></div></div></div><div class="mobile-center-container"><div class="mb_link mobile_link1"><a href="https://www.nysportsday.com/sports-betting/">Sportsbooks</a></div><div class="site-branding">
<a href="https://www.nysportsday.com/" rel="home">
<span class="logo-m"><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" alt="nysportsday.com" height="344" width="500" /></span>
</a></div><div class="mb_link mobile_link2"><a href="https://www.nysportsday.com/sports-betting/bonus/">Bonuses</a></div></div><nav id="site-navigation" class="main-navigation"><div class="menu-menu-container"><ul id="primary-menu-left" class="menu"><li id="menu-item-60742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60742 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/">Sports Betting Apps</a><ul class="sub-menu"><li id="menu-item-66325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66325 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars NY</a></li><li id="menu-item-66307" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66307 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY</a></li><li id="menu-item-71726" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71726 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY</a></li><li id="menu-item-67284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67284 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/pointsbet/">PointsBet NY</a></li><li id="menu-item-66324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66324 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers NY</a></li><li id="menu-item-66326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66326 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY</a></li><li id="menu-item-67820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67820 bonus-mega-menu-item"><a href="https://www.nysportsday.com/revenue/">Revenue Info</a></li></ul></li><li id="menu-item-66331" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66331 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/bonus/">Sportsbook Bonuses</a></li><li id="menu-item-69700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-69700 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/">Best NY Odds</a><ul class="sub-menu"><li id="menu-item-70305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70305 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/parlay/">Parlay Betting Calculator</a></li></ul></li><li id="menu-item-65523" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65523 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sportsbooks/">Sportsbook Locations</a></li><li id="menu-item-69699" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69699 bonus-mega-menu-item"><a href="#">NY Teams</a><ul class="sub-menu"><li id="menu-item-56860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56860 bonus-mega-menu-item"><a href="https://www.nysportsday.com/nets/">BKN Nets</a></li><li id="menu-item-56857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56857 bonus-mega-menu-item"><a href="https://www.nysportsday.com/devils/">NJ Devils</a></li><li id="menu-item-56863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56863 bonus-mega-menu-item"><a href="https://www.nysportsday.com/giants/">NY Giants</a></li><li id="menu-item-56858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56858 bonus-mega-menu-item"><a href="https://www.nysportsday.com/islanders/">NY Islanders</a></li><li id="menu-item-56862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56862 bonus-mega-menu-item"><a href="https://www.nysportsday.com/jets/">NY Jets</a></li><li id="menu-item-56861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56861 bonus-mega-menu-item"><a href="https://www.nysportsday.com/knicks/">NY Knicks</a></li><li id="menu-item-56864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56864 bonus-mega-menu-item"><a href="https://www.nysportsday.com/mets/">NY Mets</a></li><li id="menu-item-56859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56859 bonus-mega-menu-item"><a href="https://www.nysportsday.com/rangers/">NY Rangers</a></li><li id="menu-item-56865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56865 bonus-mega-menu-item"><a href="https://www.nysportsday.com/yankees/">NY Yankees</a></li></ul></li><li id="menu-item-56830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56830 bonus-mega-menu-item"><a href="#">Columnists</a><ul class="sub-menu"><li id="menu-item-56273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56273 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</a></li><li id="menu-item-56272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56272 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/hal-bock/">Hal Bock</a></li><li id="menu-item-56279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56279 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/leslie-treff/">Leslie Treff</a></li><li id="menu-item-56278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56278 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/admin/">Joe McDonald</a></li><li id="menu-item-60167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60167 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/esposito/">Andy Esposito</a></li><li id="menu-item-56275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56275 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/lloyd-carroll/">Lloyd Carroll</a></li><li id="menu-item-56276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56276 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/jeff-moeller/">Jeff Moeller</a></li><li id="menu-item-56274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56274 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/howie-karpin/">Howie Karpin</a></li><li id="menu-item-56277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56277 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/david-russell/">David Russell</a></li></ul></li></ul></div></nav><div class="search-toggle-wrap">
<ion-icon name="search"></ion-icon></div><div class="search-form-wrap"><form role="search" aria-label="Search for:" method="get" class="search-form" action="https://www.nysportsday.com">
<label for="search-form-1">
<input type="search" id="search-form-1" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<button type="submit" class="btn btn-primary search-submit"><ion-icon name="search"></ion-icon></button></form></div></header><div id="primary" class="content-area"><main id="main" class="site-main"><article id="post-71300" class="post-71300 post type-post status-publish format-standard has-post-thumbnail hentry category-new-york-mets category-sports-betting"><div class="hero mb-0 post-hero image-bg"><div class="bg" style='background-image:url(https://www.nysportsday.com/wp-content/uploads/NY-Mets6-1024x683.jpg);'></div><div class="container"><div class="row justify-content-between"><div class="col-md-12"><div class="featured-category">
<a href="https://www.nysportsday.com/category/gambling/sports-betting/">
Sports Betting </a></div><h1 class="interior-header">New York Mets World Series Odds 2022</h1><div class="post-meta"><div class="author"><div class="icon" style="background-image: url(https://www.nysportsday.com/wp-content/uploads/Hannah-Vanbiber-259x300-1.png);"></div><div>
<span class="lbl">Written By:</span>
<a href="https://www.nysportsday.com/author/hannah-vanbiber/">
Hannah Vanbiber </a></div></div><div class="dateblock published"><div class="icon">
<ion-icon name="newspaper-outline"></ion-icon></div><div>
<span class="lbl">Published:</span>
Jul 11, 2022</div></div><div class="dateblock updated"><div class="icon">
<ion-icon name="calendar-outline"></ion-icon></div><div>
<span class="lbl">Updated:</span>
Jul 11, 2022</div></div><div class="post-shares hide-mobile"><div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=New York Mets World Series Odds 2022&url=https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/&title=New York Mets World Series Odds 2022" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a></div></div></div></div></div></div><div class="entry-content"><div class="container"><div class="row"><div class="col-md-12"><p>The New York Mets are second in the National League, but after building a big lead in the NL East, they are in danger this week of falling behind in the division. The Mets&#8217; 2022 World Series odds are getting longer because of that.</p><p>The team from Queens is recovering well from a disappointing season riddled with injuries and controversy last year, but the team is showing a stunning recovery this year, with New York fans pumped up for the postseason.</p><p><a href="https://www.nysportsday.com/odds/mets/">The Mets</a> led the National League nearly every week since Opening Day through the end of June, posting great stats on the road and at home in Citi Field. Francisco Lindor, in particular, seems to have got into his New York groove and is on fire this season. It&#8217;s a different team from 2021, and we&#8217;re excited to see if they can keep up the momentum.</p><p style="text-align: center;"><strong><a href="https://www.nysportsday.com/visit/caesars/">Get a $1,500 risk-free bet with Caesars NY promo code SHARPBET15</a></strong></p><p>So, what do the Mets&#8217; odds look like to win the World Series? <a href="https://www.nysportsday.com/sports-betting/">New York sports bettors</a> can get all the odds on Mets here.</p><h2>NY Mets Odds to Win the World Series</h2><p>The Mets (53-33) are among the top five favorites to win the World Series and trail only the LA Dodgers (56-29) in the National League.</p><div class="metabet-sideoddstile metabet-size-350x400 metabet-query-bbm/mlb_winner metabet-site-id-nysportsday"></div><p>&nbsp;</p><p>The team from Queens has shaped up to be a formidable force this season, even with aces Jacob deGrom and Max Scherzer out for an extended period of time. Stars like Lindor, Eduardo Escobar, and <a href="https://www.nysportsday.com/2022/07/11/pete-alonso-home-run-odds/">Pete Alonso</a> have held the team together and continued to rack up wins.</p><p><strong>Don&#8217;t forget the Bronx Bombers:</strong> <a href="https://www.nysportsday.com/2022/07/11/ny-yankees-world-series-odds-2022/">New York Yankees World Series Odds</a></p><h2>NY Mets Odds to Win the NL Pennant</h2><p>Odds the win the NL Pennant are even stronger for the Mets:</p><div class="metabet-sideoddstile metabet-size-350x400 metabet-query-bbm/mlb_winner_nl metabet-site-id-nysportsday"></div><p>&nbsp;</p><p>The Mets have led the NL East for most of the season and had a comfortable lead in the National League as a whole in June. As of July 11, however, the Dodgers built a 3.5-game lead over the Mets in the National League. In the AL, <a href="https://www.nysportsday.com/odds/yankees/">the Yankees</a> and the Houston Astros both have better records.</p><h2>NY Mets Update</h2><p>The Mets went 4-3 in two series against the Cincinnati Reds and the Miami Marlins last week but still fell behind the Dodgers because LA went 7-0 last week.</p><p>This week, New York will play seven road games heading into the All-Star break. First up is a three-game set against the Atlanta Braves with the NL East lead on the line. The Mets lead the division by 1.5 games but could fall behind the reigning World Series champions if they drop all three games. After that, New York will head to the Windy City for four games against the Chicago Cubs.</p><p><em>AP Photo/John Minchillo</em></p></div></div></div><div class="post-shares show-mobile"><div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=New York Mets World Series Odds 2022&url=https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2022/07/11/ny-mets-world-series-odds-2022/&title=New York Mets World Series Odds 2022" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a></div><div class="container mt-4"><div class="row"><div class="col-md-12"><div class="author-box card"><h5 class="card-header">About the Author</h5><div class="card-body"><div class="avatar pr-3">
<img src="https://www.nysportsday.com/wp-content/uploads/Hannah-Vanbiber-259x300-1.png" width="259" height="300" /></div><div class="info"><h3 class="mb-0"><a href="https://www.nysportsday.com/author/hannah-vanbiber/">Hannah Vanbiber</h3></a><h6 class="mb-0"></h6><div class="author-socials"></div><div class="bio">
Hannah Vanbiber is an LSU fan by birth, Cavaliers fan by marriage, and Mets fan by choice. She started her journalism career in Chattanooga, Tennessee, as a reporter covering local sports, entertainment, and business in the East Tennessee area. She was the leading editor for the launch of a new sports magazine brand by Chattanooga’s CityScope Magazine. Hannah moved to New York City in 2013 and started writing freelance for several clients including newspapers, magazines, and corporate brands. She also joined the nonprofit world and spent eight years working in fundraising, most recently as the Director of Volunteers at New York City’s oldest homeless services organization. She is now a full-time freelance writer, editor, and reporter, covering women’s sports and sports betting in the New York metropolitan area. Hannah lives in Manhattan with her husband, Ben Wagner, whose loyalty to LeBron James knows no bounds.</div></div></div></div></div></div></div></div></article></main></div><div class="social-row"><div class="container"><div class="row"><div class="col-md-4"><p>Get connected with us on Social Media</p></div><div class="col-md-8 socials">
<a href="https://www.facebook.com/nysportsday"><i class="dashicons dashicons-facebook-alt"></i></a><a href="https://twitter.com/nysportsday"><i class="dashicons dashicons-twitter"></i></a><a href="https://www.instagram.com/nysportsday/"><i class="dashicons dashicons-instagram"></i></a><a href="https://www.youtube.com/user/NYSportsDay"><i class="dashicons dashicons-youtube"></i></a></div></div></div></div><footer class="footer-global"><div class="container"><div class="row"><div class="col-md-3"><h5>NY Sports Day</h5><p>NY Sports Day is an independent site that covers New York sports since 2004. We are fully credentialed by all nine major New York sports teams.</p></div><div class="col-md-3"><h5><a href="https://www.nysportsday.com/odds/">Best NY Sports Odds</a></h5><ul><li><a href="/yankees/">New York Yankees</a></li><li><a href="https://www.nysportsday.com/mets/">New York Mets</a></li><li><a href="https://www.nysportsday.com/giants/">New York Giants</a></li><li><a href="https://www.nysportsday.com/jets/">New York Jets</a></li></ul></div><div class="col-md-3"><h5><a href="https://www.nysportsday.com/sports-betting/">NY Sports Betting &amp; Casino</a></h5><ul><li><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sportsbook Promo Codes</a></li><li><a href="https://www.nysportsday.com/revenue/">New York Revenue Info</a></li><li><a href="https://www.nysportsday.com/online-casinos/">NY Online Casinos</a></li><li><a href="https://www.nysportsday.com/sportsbooks/">NY Sportsbook Locations</a></li></ul></div><div class="col-md-3"><h5>NY Sportsbook Reviews</h5><ul><li><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars Sportsbook NY</a></li><li><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY Promo Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY Bonus Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY Promo Code</a></li></ul></div></div></div></footer><div class="footer-copyright">
Copyright © 2022 NYSportsDay - All rights reserved. <a href="https://www.nysportsday.com/about/">About </a> | <a href="https://www.nysportsday.com/contact/">Contact </a> | <a href="https://www.nysportsday.com/privacy-policy/">Privacy Policy</a> | <a href="https://www.nysportsday.com/responsible-gaming/">Responsible Gaming</a></div><div class="modal fade" id="gameModal" tabindex="-1" role="dialog" aria-labelledby="gameModalLabel" aria-hidden="true"><div class="modal-dialog modal-dialog-centered" role="document"><div class="modal-content"><div class="modal-header"><h5 class="modal-title" id="gameModalLabel">Modal title</h5>
<button type="button" class="close" data-dismiss="modal" aria-label="Close">
<span aria-hidden="true">&times;</span>
</button></div><div class="modal-body">
<iframe width="100%" height="550" src=""></iframe></div></div></div></div> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/2b97f72de303df3adba850245ca07423.js?ver=97548' id='chub-get-cta-v2-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/a39eef2b6e8c2e244829b67a5a3a2cc6.js?ver=6f7dc' id='regenerator-runtime-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/d4998cb41d67d730b95df1a2fd5fa348.js?ver=f46f5' id='wp-polyfill-js'></script> <script type='text/javascript' id='contact-form-7-js-extra'>/*  */
var wpcf7 = {"api":{"root":"https:\/\/www.nysportsday.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/c3647deab36393f7518d164ba5911d47.js?ver=c5198' id='contact-form-7-js'></script> <script type='text/javascript' id='ta_main_js-js-extra'>/*  */
var thirsty_global_vars = {"home_url":"\/\/www.nysportsday.com","ajax_url":"https:\/\/www.nysportsday.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"visit","link_prefixes":["recommends","visit"],"post_id":"71300","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/ce961e5692c311e29b501357440157b0.js?ver=d52c4' id='ta_main_js-js'></script> <script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/aa66b29fa0a299739181b3d258f4608f.js?ver=da792' id='bootstrap-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/f95bd4f5fea43fbce913065137f79d20.js?ver=4b153' id='globaljs-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/bec53e075b4af67d999068175e75863f.js?ver=fbe29' id='bonus_mega_menu-js'></script> <script type='text/javascript' src='https://go.metabet.io/js/global.js?siteID=nysportsday&#038;ver=6.0' id='metabet-core-js-js'></script> <script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":71300,"object_key":"post","object_type":"post","term_ids":[3,21263]};</script> </body></html>

