<!doctype html><html lang="en-US"><head>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK2SCV9');</script> <meta charset="UTF-8"><link data-optimized="2" rel="stylesheet" href="https://www.nysportsday.com/wp-content/litespeed/css/d7ffd0b88f8efc0e0c4bd2dcafdf4ab9.css?ver=43e14" /><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><link rel="profile" href="https://gmpg.org/xfn/11"><link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&display=swap" rel="stylesheet"> <script type="module" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.esm.js"></script> <script nomodule="" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.js"></script> <link rel="preconnect" href="https://us1.catenaus.com/" crossorigin><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <script>window.dataLayer = window.dataLayer || [];
                window.dataLayer.push({
category: `Hockey,New York Islanders`,
tags: ``,
event: `Page Data`,
regionName: ``,
pageTemplate: ``
});</script> <title>Schwartz On Sports: NY Post Islanders Reporter Ethan Sears - NY Sports Day</title><link rel="canonical" href="https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Schwartz On Sports: NY Post Islanders Reporter Ethan Sears - NY Sports Day" /><meta property="og:description" content="NY Post Islanders reporter Ethan Sears joins Peter to talk about the Islanders coaching change [&hellip;]" /><meta property="og:url" content="https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/" /><meta property="og:site_name" content="NY Sports Day" /><meta property="article:published_time" content="2022-05-19T14:37:57+00:00" /><meta property="og:image" content="https://www.nysportsday.com/wp-content/uploads/2NnQ9ht3_400x400.jpg" /><meta property="og:image:width" content="400" /><meta property="og:image:height" content="400" /><meta property="og:image:type" content="image/jpeg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Peter Schwartz" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="1 minute" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.nysportsday.com/#website","url":"https://www.nysportsday.com/","name":"NY Sports Day","description":"Your Gotham Sports News Source","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.nysportsday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#primaryimage","url":"https://www.nysportsday.com/wp-content/uploads/2NnQ9ht3_400x400.jpg","contentUrl":"https://www.nysportsday.com/wp-content/uploads/2NnQ9ht3_400x400.jpg","width":400,"height":400},{"@type":"WebPage","@id":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#webpage","url":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/","name":"Schwartz On Sports: NY Post Islanders Reporter Ethan Sears - NY Sports Day","isPartOf":{"@id":"https://www.nysportsday.com/#website"},"primaryImageOfPage":{"@id":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#primaryimage"},"datePublished":"2022-05-19T14:37:57+00:00","dateModified":"2022-05-19T14:37:57+00:00","author":{"@id":"https://www.nysportsday.com/#/schema/person/ad3a22088cda5e0ec0af2551030e0f99"},"breadcrumb":{"@id":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#breadcrumb"},"inLanguage":"en-US","potentialAction":{"@type":"ListenAction","target":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#podcast_player_70606","object":{"@id":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#/schema/podcast"}},"mainEntityOfPage":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#/schema/podcast"},{"@type":"BreadcrumbList","@id":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.nysportsday.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://www.nysportsday.com/news/"},{"@type":"ListItem","position":3,"name":"Schwartz On Sports: NY Post Islanders Reporter Ethan Sears"}]},{"@type":"Person","@id":"https://www.nysportsday.com/#/schema/person/ad3a22088cda5e0ec0af2551030e0f99","name":"Peter Schwartz","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.nysportsday.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/ce3b9490c1a6bb7f8acf77b7871ed35a?s=96&d=retro&r=g","contentUrl":"https://secure.gravatar.com/avatar/ce3b9490c1a6bb7f8acf77b7871ed35a?s=96&d=retro&r=g","caption":"Peter Schwartz"},"description":"Peter covers the Islanders for New York Sports Day while also writing about general sports in the New York/New Jersey area. In addition to his column, Peter also hosts his “Schwartz On Sports” podcast as he interviews players, coaches, and other sports personalities. He is also currently a sports anchor for WFAN Radio, CBS Sports Radio, and WCBS 880 radio while also serving as the public address announcer for the New York Cosmos soccer club. Peter spent 8 years as the radio play by play voice for the New York Dragons of the Arena Football League. He was also the radio play by play announcer for the XFL’s NY/NJ Hitmen in 2001 and the radio play by play announcer for the New York Saints of the Major Indoor Lacrosse League from 1993 to 1996. You can follow Peter on Twitter at @SchwartzSports","url":"https://www.nysportsday.com/author/peter-schwartz/"},{"@type":["PodcastEpisode","OnDemandEvent"],"@id":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#/schema/podcast","eventAttendanceMode":"https://schema.org/OnlineEventAttendanceMode","location":{"@type":"VirtualLocation","url":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/","@id":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/#webpage"},"url":"https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/","name":"Schwartz On Sports: NY Post Islanders Reporter Ethan Sears - NY Sports Day","datePublished":"2022-05-19","description":"NY Post Islanders reporter Ethan Sears joins Peter to talk about the Islanders coaching change [&hellip;]","duration":"P19M","associatedMedia":{"contentUrl":"https://episodes.castos.com/nysportsday/9f6d1e04-cbec-4b08-bd82-6866d07c9aa3-NYI-Ethan-Sears-051922.mp3","contentSize":false,"@type":"MediaObject"}}]}</script> <style id='global-styles-inline-css' type='text/css'>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</style> <script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/073b0eb07bc32242cbdf38c34712e4b2.js?ver=97ee0' id='jquery-migrate-js'></script> <link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.nysportsday.com/feed/podcast" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-180x180.png" /><meta name="msapplication-TileImage" content="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-270x270.png" /><style>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</style></head><body class="post-template-default single single-post postid-70606 single-format-standard">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PK2SCV9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><header class="site-header"><div class="bonus-mega-menu mega-menu"><ul id="menu-mega-menu" class="bonus-mega-menu-list mega-menu-list"><li id="menu-item-69887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69887 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>NY Baseball &#038; Football</a><ul class="sub-menu"><li id="menu-item-69888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69888 bonus-mega-menu-item"><a href="https://www.nysportsday.com/yankees/">New York Yankees</a></li><li id="menu-item-69889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69889 bonus-mega-menu-item"><a href="https://www.nysportsday.com/mets/">New York Mets</a></li><li id="menu-item-69890" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69890 bonus-mega-menu-item"><a href="https://www.nysportsday.com/giants/">New York Giants</a></li><li id="menu-item-69891" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69891 bonus-mega-menu-item"><a href="https://www.nysportsday.com/jets/">New York Jets</a></li></ul></li><li id="menu-item-69892" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69892 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>NY Hockey &#038; Basketball</a><ul class="sub-menu"><li id="menu-item-69893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69893 bonus-mega-menu-item"><a href="https://www.nysportsday.com/islanders/">New York Islanders</a></li><li id="menu-item-69894" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69894 bonus-mega-menu-item"><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li><li id="menu-item-69895" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69895 bonus-mega-menu-item"><a href="https://www.nysportsday.com/knicks/">New York Knicks</a></li><li id="menu-item-69896" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69896 bonus-mega-menu-item"><a href="https://www.nysportsday.com/nets/">Brooklyn Nets</a></li></ul></li><li id="menu-item-69897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69897 bonus-mega-menu-item-expand-submenu bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>Sports Betting</a><ul class="sub-menu"><li id="menu-item-69900" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69900 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/">New York Sports Betting</a></li><li id="menu-item-69901" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69901 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sportsbook Bonuses</a></li><li id="menu-item-69902" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69902 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings Sportsbook NY</a></li><li id="menu-item-70023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70023 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars Sportsbook NY</a></li></ul></li><li id="menu-item-69904" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69904 bonus-mega-menu-item-custom-link-submenu bonus-mega-menu-item"><a>Tools &#038; Contact</a><ul class="sub-menu"><li id="menu-item-70304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70304 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/parlay/">Compare Parlay Odds</a></li><li id="menu-item-69906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69906 bonus-mega-menu-item"><a href="https://www.nysportsday.com/about/">About</a></li><li id="menu-item-69905" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69905 bonus-mega-menu-item"><a href="https://www.nysportsday.com/contact/">Contact</a></li></ul></li></ul></div><div class="mega-menu-toggle"><div class="menu"><div class="bar"></div><div class="bar"></div><div class="bar"></div></div></div><div class="mobile-center-container"><div class="mb_link mobile_link1"><a href="https://www.nysportsday.com/sports-betting/">Sportsbooks</a></div><div class="site-branding">
<a href="https://www.nysportsday.com/" rel="home">
<span class="logo-m"><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" alt="nysportsday.com" /></span>
</a></div><div class="mb_link mobile_link2"><a href="https://www.nysportsday.com/sports-betting/bonus/">Bonuses</a></div></div><nav id="site-navigation" class="main-navigation"><div class="menu-menu-container"><ul id="primary-menu-left" class="menu"><li id="menu-item-60742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60742 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/">Sports Betting Apps</a><ul class="sub-menu"><li id="menu-item-66326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66326 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY</a></li><li id="menu-item-66325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66325 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars NY</a></li><li id="menu-item-66307" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66307 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY</a></li><li id="menu-item-64261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-64261 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY</a></li><li id="menu-item-67284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67284 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/pointsbet/">PointsBet NY</a></li><li id="menu-item-66324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66324 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers NY</a></li><li id="menu-item-67820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67820 bonus-mega-menu-item"><a href="https://www.nysportsday.com/revenue/">Revenue Info</a></li></ul></li><li id="menu-item-66331" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66331 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sports-betting/bonus/">Sportsbook Bonuses</a></li><li id="menu-item-69700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-69700 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/">Best NY Odds</a><ul class="sub-menu"><li id="menu-item-70305" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70305 bonus-mega-menu-item"><a href="https://www.nysportsday.com/odds/parlay/">Compare Parlay Odds</a></li></ul></li><li id="menu-item-65523" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65523 bonus-mega-menu-item"><a href="https://www.nysportsday.com/sportsbooks/">Sportsbook Locations</a></li><li id="menu-item-69699" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-69699 bonus-mega-menu-item"><a href="#">NY Teams</a><ul class="sub-menu"><li id="menu-item-56860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56860 bonus-mega-menu-item"><a href="https://www.nysportsday.com/nets/">BKN Nets</a></li><li id="menu-item-56857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56857 bonus-mega-menu-item"><a href="https://www.nysportsday.com/devils/">NJ Devils</a></li><li id="menu-item-56863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56863 bonus-mega-menu-item"><a href="https://www.nysportsday.com/giants/">NY Giants</a></li><li id="menu-item-56858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56858 bonus-mega-menu-item"><a href="https://www.nysportsday.com/islanders/">NY Islanders</a></li><li id="menu-item-56862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56862 bonus-mega-menu-item"><a href="https://www.nysportsday.com/jets/">NY Jets</a></li><li id="menu-item-56861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56861 bonus-mega-menu-item"><a href="https://www.nysportsday.com/knicks/">NY Knicks</a></li><li id="menu-item-56864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56864 bonus-mega-menu-item"><a href="https://www.nysportsday.com/mets/">NY Mets</a></li><li id="menu-item-56859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56859 bonus-mega-menu-item"><a href="https://www.nysportsday.com/rangers/">NY Rangers</a></li><li id="menu-item-56865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56865 bonus-mega-menu-item"><a href="https://www.nysportsday.com/yankees/">NY Yankees</a></li></ul></li><li id="menu-item-56830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56830 bonus-mega-menu-item"><a href="#">Columnists</a><ul class="sub-menu"><li id="menu-item-56273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56273 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</a></li><li id="menu-item-56272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56272 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/hal-bock/">Hal Bock</a></li><li id="menu-item-56279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56279 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/leslie-treff/">Leslie Treff</a></li><li id="menu-item-56278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56278 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/admin/">Joe McDonald</a></li><li id="menu-item-60167" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60167 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/esposito/">Andy Esposito</a></li><li id="menu-item-56275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56275 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/lloyd-carroll/">Lloyd Carroll</a></li><li id="menu-item-56276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56276 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/jeff-moeller/">Jeff Moeller</a></li><li id="menu-item-56274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56274 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/howie-karpin/">Howie Karpin</a></li><li id="menu-item-56277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56277 bonus-mega-menu-item"><a href="https://www.nysportsday.com/author/david-russell/">David Russell</a></li></ul></li></ul></div></nav><div class="search-toggle-wrap">
<ion-icon name="search"></ion-icon></div><div class="search-form-wrap"><form role="search" aria-label="Search for:" method="get" class="search-form" action="https://www.nysportsday.com">
<label for="search-form-1">
<input type="search" id="search-form-1" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<button type="submit" class="btn btn-primary search-submit"><ion-icon name="search"></ion-icon></button></form></div></header><div id="primary" class="content-area"><main id="main" class="site-main"><article id="post-70606" class="post-70606 post type-post status-publish format-standard has-post-thumbnail hentry category-hockey category-new-york-islanders tag-featured-article"><div class="hero mb-0 post-hero detached-image"><div class="bg"></div><div class="container"><div class="row justify-content-between"><div class="col-md-12"><div class="featured-category">
<a href="https://www.nysportsday.com/category/hockey/new-york-islanders/">
New York Islanders </a></div><h1 class="interior-header">Schwartz On Sports: NY Post Islanders Reporter Ethan Sears</h1><div class="post-meta"><div class="author"><div class="icon" style="background-image: url(https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg);"></div><div>
<span class="lbl">Written By:</span>
<a href="https://www.nysportsday.com/author/peter-schwartz/">
Peter Schwartz </a></div></div><div class="dateblock published"><div class="icon">
<ion-icon name="newspaper-outline"></ion-icon></div><div>
<span class="lbl">Published:</span>
May 19, 2022</div></div><div class="dateblock updated"><div class="icon">
<ion-icon name="calendar-outline"></ion-icon></div><div>
<span class="lbl">Updated:</span>
May 19, 2022</div></div><div class="post-shares hide-mobile"><div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=Schwartz On Sports: NY Post Islanders Reporter Ethan Sears&url=https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/&title=Schwartz On Sports: NY Post Islanders Reporter Ethan Sears" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a></div></div></div></div></div></div><div class="entry-content"><div class="container"><div class="row"><div class="col-md-12"><div class="detached-image">
<img src="https://www.nysportsday.com/wp-content/uploads/2NnQ9ht3_400x400.jpg" /></div><p>NY Post Islanders reporter Ethan Sears joins Peter to talk about the Islanders coaching change and the off-season.  They also touch on the Rangers in the playoffs.</p><div class="podcast_player"><div class="castos-player dark-mode" data-episode="70606" data-player_id="3669142168"><div class="player"><div class="player__main"><div class="player__artwork player__artwork-70606">
<img src="https://www.nysportsday.com/wp-content/plugins/seriously-simple-podcasting/assets/images/no-album-art.png" alt="NY Sports Day" title="NY Sports Day"></div><div class="player__body"><div class="currently-playing"><div class="show player__podcast-title">
NY Sports Day</div><div class="episode-title player__episode-title">Schwartz On Sports: NY Post Islanders Reporter Ethan Sears</div></div><div class="play-progress"><div class="play-pause-controls">
<button title="Play" class="play-btn">
<span class="screen-reader-text">Play Episode</span>
</button>
<button title="Pause" class="pause-btn hide">
<span class="screen-reader-text">Pause Episode</span>
</button>
<img src="https://www.nysportsday.com/wp-content/plugins/seriously-simple-podcasting/assets/css/images/player/images/icon-loader.svg" class="ssp-loader hide" /></div><div>
<audio preload="none" class="clip clip-70606">
<source src="https://www.nysportsday.com/podcast-player/70606/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears.mp3">
</audio><div class="ssp-progress" title="Seek">
<span class="progress__filled"></span></div><div class="ssp-playback playback"><div class="playback__controls">
<button class="player-btn__volume" title="Mute/Unmute">
<span class="screen-reader-text">Mute/Unmute Episode</span>
</button>
<button data-skip="-10" class="player-btn__rwd" title="Rewind 10 seconds">
<span class="screen-reader-text">Rewind 10 Seconds</span>
</button>
<button data-speed="1" class="player-btn__speed" title="Playback Speed">1x</button>
<button data-skip="30" class="player-btn__fwd" title="Fast Forward 30 seconds">
<span class="screen-reader-text">Fast Forward 30 seconds</span>
</button></div><div class="playback__timers">
<time class="ssp-timer">00:00</time>
<span>/</span>
<time class="ssp-duration">00:18:42</time></div></div></div></div><nav class="player-panels-nav">
<button class="subscribe-btn" id="subscribe-btn-70606" title="Subscribe">Subscribe</button>
<button class="share-btn" id="share-btn-70606" title="Share">Share</button></nav></div></div></div><div class="player-panels player-panels-70606"><div class="subscribe player-panel subscribe-70606"><div class="close-btn close-btn-70606">
<span></span>
<span></span></div><div class="panel__inner"><div class="subscribe-icons"></div><div class="player-panel-row"><div class="title">
RSS Feed</div><div>
<input value="https://www.nysportsday.com/feed/podcast" class="input-rss input-rss-70606" readonly /></div>
<button class="copy-rss copy-rss-70606"></button></div></div></div><div class="share share-70606 player-panel"><div class="close-btn close-btn-70606">
<span></span>
<span></span></div><div class="player-panel-row"><div class="title">
Share</div><div class="icons-holder">
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/?post_type=post&p=70606&t=Schwartz On Sports: NY Post Islanders Reporter Ethan Sears" target="_blank" rel="noopener noreferrer" class="share-icon facebook" title="Share on Facebook">
<span></span>
</a>
<a href="https://twitter.com/intent/tweet?text=https://www.nysportsday.com/?post_type=post&p=70606&url=Schwartz On Sports: NY Post Islanders Reporter Ethan Sears" target="_blank" rel="noopener noreferrer" class="share-icon twitter" title="Share on Twitter">
<span></span>
</a>
<a href="https://www.nysportsday.com/podcast-player/70606/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears.mp3" target="_blank" rel="noopener noreferrer" class="share-icon download" title="Download" download>
<span></span>
</a></div></div><div class="player-panel-row"><div class="title">
Link</div><div>
<input value="https://www.nysportsday.com/?post_type=post&p=70606" class="input-link input-link-70606" readonly /></div>
<button class="copy-link copy-link-70606" readonly=""></button></div><div class="player-panel-row"><div class="title">
Embed</div><div style="height: 10px;">
<input type="text" value='&lt;blockquote class=&quot;wp-embedded-content&quot; data-secret=&quot;myDbqaGcqQ&quot;&gt;&lt;a href=&quot;https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/&quot;&gt;Schwartz On Sports: NY Post Islanders Reporter Ethan Sears&lt;/a&gt;&lt;/blockquote&gt;&lt;iframe sandbox=&quot;allow-scripts&quot; security=&quot;restricted&quot; src=&quot;https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/embed/#?secret=myDbqaGcqQ&quot; width=&quot;500&quot; height=&quot;350&quot; title=&quot;&#8220;Schwartz On Sports: NY Post Islanders Reporter Ethan Sears&#8221; &#8212; NY Sports Day&quot; data-secret=&quot;myDbqaGcqQ&quot; frameborder=&quot;0&quot; marginwidth=&quot;0&quot; marginheight=&quot;0&quot; scrolling=&quot;no&quot; class=&quot;wp-embedded-content&quot;&gt;&lt;/iframe&gt;&lt;script type=&quot;text/javascript&quot;&gt;
/*! This file is auto-generated */
!function(c,d){&quot;use strict&quot;;var e=!1,o=!1;if(d.querySelector)if(c.addEventListener)e=!0;if(c.wp=c.wp||{},!c.wp.receiveEmbedMessage)if(c.wp.receiveEmbedMessage=function(e){var t=e.data;if(t)if(t.secret||t.message||t.value)if(!/[^a-zA-Z0-9]/.test(t.secret)){for(var r,a,i,s=d.querySelectorAll(&#039;iframe[data-secret=&quot;&#039;+t.secret+&#039;&quot;]&#039;),n=d.querySelectorAll(&#039;blockquote[data-secret=&quot;&#039;+t.secret+&#039;&quot;]&#039;),o=0;o&lt;n.length;o++)n[o].style.display=&quot;none&quot;;for(o=0;o&lt;s.length;o++)if(r=s[o],e.source===r.contentWindow){if(r.removeAttribute(&quot;style&quot;),&quot;height&quot;===t.message){if(1e3&lt;(i=parseInt(t.value,10)))i=1e3;else if(~~i&lt;200)i=200;r.height=i}if(&quot;link&quot;===t.message)if(a=d.createElement(&quot;a&quot;),i=d.createElement(&quot;a&quot;),a.href=r.getAttribute(&quot;src&quot;),i.href=t.value,i.host===a.host)if(d.activeElement===r)c.top.location.href=t.value}}},e)c.addEventListener(&quot;message&quot;,c.wp.receiveEmbedMessage,!1),d.addEventListener(&quot;DOMContentLoaded&quot;,t,!1),c.addEventListener(&quot;load&quot;,t,!1);function t(){if(!o){o=!0;for(var e,t,r,a=-1!==navigator.appVersion.indexOf(&quot;MSIE 10&quot;),i=!!navigator.userAgent.match(/Trident.*rv:11\./),s=d.querySelectorAll(&quot;iframe.wp-embedded-content&quot;),n=0;n&lt;s.length;n++){if(!(r=(t=s[n]).getAttribute(&quot;data-secret&quot;)))r=Math.random().toString(36).substr(2,10),t.src+=&quot;#?secret=&quot;+r,t.setAttribute(&quot;data-secret&quot;,r);if(a||i)(e=t.cloneNode(!0)).removeAttribute(&quot;security&quot;),t.parentNode.replaceChild(e,t);t.contentWindow.postMessage({message:&quot;ready&quot;,secret:r},&quot;*&quot;)}}}}(window,document);
&lt;/script&gt;
' class="input-embed input-embed-70606" readonly /></div>
<button class="copy-embed copy-embed-70606"></button></div></div></div></div></div><div class="podcast_meta"><aside><p><a href="https://www.nysportsday.com/podcast-download/70606/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears.mp3?ref=download" title="Schwartz On Sports: NY Post Islanders Reporter Ethan Sears " class="podcast-meta-download">Download file</a> | <a href="https://www.nysportsday.com/podcast-download/70606/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears.mp3?ref=new_window" target="_blank" title="Schwartz On Sports: NY Post Islanders Reporter Ethan Sears " class="podcast-meta-new-window">Play in new window</a> | <span class="podcast-meta-duration">Duration: 00:18:42</span> | <span class="podcast-meta-date">Recorded on May 19, 2022</span></p></aside></div></div></div></div><div class="post-shares show-mobile"><div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
<a href="https://twitter.com/share?text=Schwartz On Sports: NY Post Islanders Reporter Ethan Sears&url=https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2022/05/19/schwartz-on-sports-ny-post-islanders-reporter-ethan-sears/&title=Schwartz On Sports: NY Post Islanders Reporter Ethan Sears" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a></div><div class="container mt-4"><div class="row"><div class="col-md-12"><div class="author-box card"><h5 class="card-header">About the Author</h5><div class="card-body"><div class="avatar pr-3">
<img src="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" /></div><div class="info"><h3 class="mb-0"><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</h3></a><h6 class="mb-0"></h6><div class="author-socials"></div><div class="bio">
Peter covers the Islanders for New York Sports Day while also writing about general sports in the New York/New Jersey area. In addition to his column, Peter also hosts his “Schwartz On Sports” podcast as he interviews players, coaches, and other sports personalities. He is also currently a sports anchor for WFAN Radio, CBS Sports Radio, and WCBS 880 radio while also serving as the public address announcer for the New York Cosmos soccer club. Peter spent 8 years as the radio play by play voice for the New York Dragons of the Arena Football League. He was also the radio play by play announcer for the XFL’s NY/NJ Hitmen in 2001 and the radio play by play announcer for the New York Saints of the Major Indoor Lacrosse League from 1993 to 1996. You can follow Peter on Twitter at @SchwartzSports</div></div></div></div></div></div></div></div></article></main></div><div class="social-row"><div class="container"><div class="row"><div class="col-md-4"><p>Get connected with us on Social Media</p></div><div class="col-md-8 socials">
<a href="https://www.facebook.com/nysportsday"><i class="dashicons dashicons-facebook-alt"></i></a><a href="https://twitter.com/nysportsday"><i class="dashicons dashicons-twitter"></i></a><a href="https://www.instagram.com/nysportsday/"><i class="dashicons dashicons-instagram"></i></a><a href="https://www.youtube.com/user/NYSportsDay"><i class="dashicons dashicons-youtube"></i></a></div></div></div></div><footer class="footer-global"><div class="container"><div class="row"><div class="col-md-3"><h5>NY Sports Day</h5><p>NY Sports Day is an independent site that covers New York sports since 2004. We are fully credentialed by all nine major New York sports teams.</p></div><div class="col-md-3"><h5>NY Sports</h5><ul><li><a href="/yankees/">New York Yankees</a></li><li><a href="https://www.nysportsday.com/mets/">New York Mets</a></li><li><a href="https://www.nysportsday.com/giants/">New York Giants</a></li><li><a href="https://www.nysportsday.com/jets/">New York Jets</a></li></ul></div><div class="col-md-3"><h5><a href="https://www.nysportsday.com/sports-betting/">NY Sports Betting</a></h5><ul><li><a href="https://www.nysportsday.com/sports-betting/draftkings/">DraftKings NY Promo Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/betmgm/">BetMGM NY Bonus Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/caesars/">Caesars Sportsbook NY</a></li><li><a href="https://www.nysportsday.com/sports-betting/betrivers/">BetRivers NY </a></li></ul></div><div class="col-md-3"><h5>NY Sportsbook Reviews</h5><ul><li><a href="https://www.nysportsday.com/sports-betting/fanduel/">FanDuel NY Promo Code</a></li><li><a href="https://www.nysportsday.com/sports-betting/pointsbet/">PointsBet NY</a></li><li><a href="https://www.nysportsday.com/sports-betting/wynnbet/">WynnBET NY</a></li><li><a href="https://www.nysportsday.com/sports-betting/bonus/">NY Sportsbook Promo Codes</a></li></ul></div></div></div></footer><div class="footer-copyright">
Copyright © 2022 NYSportsDay - All rights reserved. <a href="https://www.nysportsday.com/about/">About </a> | <a href="https://www.nysportsday.com/contact/">Contact </a> | <a href="https://www.nysportsday.com/privacy-policy/">Privacy Policy</a> | <a href="https://www.nysportsday.com/responsible-gaming/">Responsible Gaming</a></div><div class="modal fade" id="gameModal" tabindex="-1" role="dialog" aria-labelledby="gameModalLabel" aria-hidden="true"><div class="modal-dialog modal-dialog-centered" role="document"><div class="modal-content"><div class="modal-header"><h5 class="modal-title" id="gameModalLabel">Modal title</h5>
<button type="button" class="close" data-dismiss="modal" aria-label="Close">
<span aria-hidden="true">&times;</span>
</button></div><div class="modal-body">
<iframe width="100%" height="550" src=""></iframe></div></div></div></div> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/2b97f72de303df3adba850245ca07423.js?ver=97548' id='chub-get-cta-v2-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/a39eef2b6e8c2e244829b67a5a3a2cc6.js?ver=6f7dc' id='regenerator-runtime-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/d4998cb41d67d730b95df1a2fd5fa348.js?ver=f46f5' id='wp-polyfill-js'></script> <script type='text/javascript' id='contact-form-7-js-extra'>/*  */
var wpcf7 = {"api":{"root":"https:\/\/www.nysportsday.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/c3647deab36393f7518d164ba5911d47.js?ver=4222a' id='contact-form-7-js'></script> <script type='text/javascript' id='ta_main_js-js-extra'>/*  */
var thirsty_global_vars = {"home_url":"\/\/www.nysportsday.com","ajax_url":"https:\/\/www.nysportsday.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"visit","link_prefixes":["recommends","visit"],"post_id":"70606","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/ce961e5692c311e29b501357440157b0.js?ver=e432a' id='ta_main_js-js'></script> <script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/aa66b29fa0a299739181b3d258f4608f.js?ver=f334b' id='bootstrap-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/f95bd4f5fea43fbce913065137f79d20.js?ver=39903' id='globaljs-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/bec53e075b4af67d999068175e75863f.js?ver=fbe29' id='bonus_mega_menu-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.nysportsday.com/wp-content/litespeed/js/7468f19501d053ad2cbf3ac5f892b19d.js?ver=b8956' id='ssp-castos-player-js'></script> <script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":70606,"object_key":"post","object_type":"post","term_ids":[15,10,20129]};</script> </body></html>

