<!doctype html>
<html lang="en-US">
<head>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK2SCV9');</script>
<!-- End Google Tag Manager --><meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&#038;display=swap" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" rel="preload">
<script type="module" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.esm.js" defer></script>
<script nomodule="" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.js" defer></script>

	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Schwartz On Sports: Greg Picker - NY Sports Day</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://www.nysportsday.com/wp-content/cache/min/1/db55663101302a83e00fc203adc10ed0.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Schwartz On Sports: Greg Picker - NY Sports Day" />
	<meta property="og:description" content="Islanders radio analyst Greg Picker joins Peter to talk about the upcoming season and the [&hellip;]" />
	<meta property="og:url" content="https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/" />
	<meta property="og:site_name" content="NY Sports Day" />
	<meta property="article:published_time" content="2020-12-30T16:15:08+00:00" />
	<meta property="og:image" content="https://www.nysportsday.com/wp-content/uploads/Untitled-10.png" />
	<meta property="og:image:width" content="873" />
	<meta property="og:image:height" content="594" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Peter Schwartz">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="0 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.nysportsday.com/#website","url":"https://www.nysportsday.com/","name":"NY Sports Day","description":"Your Gotham Sports News Source","potentialAction":[{"@type":"SearchAction","target":"https://www.nysportsday.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/#primaryimage","inLanguage":"en-US","url":"https://www.nysportsday.com/wp-content/uploads/Untitled-10.png","width":873,"height":594},{"@type":"WebPage","@id":"https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/#webpage","url":"https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/","name":"Schwartz On Sports: Greg Picker - NY Sports Day","isPartOf":{"@id":"https://www.nysportsday.com/#website"},"primaryImageOfPage":{"@id":"https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/#primaryimage"},"datePublished":"2020-12-30T16:15:08+00:00","dateModified":"2020-12-30T16:15:08+00:00","author":{"@id":"https://www.nysportsday.com/#/schema/person/71cc1a2589b984bf6268b028c2125d34"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/"]}]},{"@type":"Person","@id":"https://www.nysportsday.com/#/schema/person/71cc1a2589b984bf6268b028c2125d34","name":"Peter Schwartz","image":{"@type":"ImageObject","@id":"https://www.nysportsday.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ce3b9490c1a6bb7f8acf77b7871ed35a?s=96&d=retro&r=g","caption":"Peter Schwartz"},"description":"Peter covers the Islanders for New York Sports Day while also writing about general sports in the New York/New Jersey area. In addition to his column, Peter also hosts his \u201cSchwartz On Sports\u201d podcast as he interviews players, coaches, and other sports personalities. He is also currently a sports anchor for WFAN Radio, CBS Sports Radio and WCBS 880 radio while also serving as the public address announcer for the New York Cosmos soccer club. Peter spent 8 years as the radio play by play voice for the New York Dragons of the Arena Football League. He was also the radio play by play announcer for the XFL\u2019s NY/NJ Hitmen in 2001 and the radio play by play announcer for the New York Saints of the Major Indoor Lacrosse League from 1993 to 1996."}]}</script>
	<!-- / Yoast SEO plugin. -->









<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.nysportsday.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>


<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.nysportsday.com/feed/podcast" />

      <meta name="onesignal" content="wordpress-plugin"/>
            
<link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-270x270.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>

<body class="post-template-default single single-post postid-59090 single-format-standard">

	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PK2SCV9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<header class="site-header">

				<div class="mega-menu">
		<div class="logo-col"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" /></noscript></div>
<div class="container">
<div class="row">
<div class="col-md-6">
<h4 class="mm-nav-label">NY Baseball &amp; Football</h4>
<ul>
<li><a href="/yankees/">New York Yankees</a></li>
<li><a href="https://www.nysportsday.com/category/baseball/new-york-mets/">New York Mets</a></li>
<li><a href="https://www.nysportsday.com/category/football/new-york-giants/">New York Giants</a></li>
<li><a href="https://www.nysportsday.com/category/football/new-york-jets/">New York Jets</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">NY Hockey &amp; Basketball</h4>
<ul>
<li><a href="https://www.nysportsday.com/category/hockey/new-york-islanders/">New York Islanders</a></li>
<li><a href="https://www.nysportsday.com/category/hockey/new-york-rangers/">New York Rangers</a></li>
<li><a href="https://www.nysportsday.com/category/basketball/new-york-knicks/">New York Knicks</a></li>
<li><a href="https://www.nysportsday.com/category/basketball/new-jersey-nets/">New Jersey Nets</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">Other</h4>
<ul>
<li><a href="https://www.nysportsday.com/new-york-sports-betting/">New York Sports Betting</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">Contact</h4>
<ul>
<li><a href="https://www.nysportsday.com/about/">About</a></li>
<li><a href="https://www.nysportsday.com/contact-us/">Contact</a></li>
</ul>
</div>
</div>
</div>
		</div>
		
	
		<div class="mega-menu-toggle">
			<div class="menu">
				<div class="bar"></div>
				<div class="bar"></div>
				<div class="bar"> </div>
			</div>
		</div>


	
		<div class="site-branding">
			<a href="https://www.nysportsday.com/" rel="home">
				<span class="logo-m"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="nysportsday.com" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png"/><noscript><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" alt="nysportsday.com"/></noscript></span>
			</a>
		</div>	

		<nav id="site-navigation" class="main-navigation">
			<div class="menu-menu-container"><ul id="primary-menu-left" class="menu"><li id="menu-item-15689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-15689"><a href="https://www.nysportsday.com/">Home</a></li>
<li id="menu-item-15690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15690"><a href="https://www.nysportsday.com/category/baseball/">Baseball</a>
<ul class="sub-menu">
	<li id="menu-item-56865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56865"><a href="https://www.nysportsday.com/yankees/">NY Yankees</a></li>
	<li id="menu-item-56864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56864"><a href="https://www.nysportsday.com/mets/">NY Mets</a></li>
</ul>
</li>
<li id="menu-item-15693" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15693"><a href="https://www.nysportsday.com/category/football/">Football</a>
<ul class="sub-menu">
	<li id="menu-item-56862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56862"><a href="https://www.nysportsday.com/jets/">NY Jets News</a></li>
	<li id="menu-item-56863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56863"><a href="https://www.nysportsday.com/giants/">NY Giants</a></li>
</ul>
</li>
<li id="menu-item-15696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15696"><a href="https://www.nysportsday.com/category/basketball/">Basketball</a>
<ul class="sub-menu">
	<li id="menu-item-56860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56860"><a href="https://www.nysportsday.com/nets/">Brooklyn Nets</a></li>
	<li id="menu-item-56861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56861"><a href="https://www.nysportsday.com/knicks/">NY Knicks</a></li>
</ul>
</li>
<li id="menu-item-15699" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-15699"><a href="https://www.nysportsday.com/category/hockey/">Hockey</a>
<ul class="sub-menu">
	<li id="menu-item-56858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56858"><a href="https://www.nysportsday.com/islanders/">NY Islanders</a></li>
	<li id="menu-item-56859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56859"><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li>
	<li id="menu-item-56857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56857"><a href="https://www.nysportsday.com/devils/">NJ Devils</a></li>
</ul>
</li>
<li id="menu-item-15711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15711"><a href="https://www.nysportsday.com/category/other-sports/">Other</a>
<ul class="sub-menu">
	<li id="menu-item-56833" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56833"><a href="https://www.nysportsday.com/sports-betting/">NY Sports Betting</a></li>
	<li id="menu-item-56831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56831"><a href="https://www.nysportsday.com/online-casinos/">NY Online Casinos</a></li>
	<li id="menu-item-56832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56832"><a href="https://www.nysportsday.com/nj/">NJ Online Gambling</a></li>
	<li id="menu-item-15718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15718"><a href="https://www.nysportsday.com/category/tennis/us-open-tennis/">US Open Tennis</a></li>
	<li id="menu-item-15712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15712"><a href="https://www.nysportsday.com/category/boxing/">Boxing</a></li>
	<li id="menu-item-15713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15713"><a href="https://www.nysportsday.com/category/golf/">Golf</a></li>
	<li id="menu-item-15714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15714"><a href="https://www.nysportsday.com/category/soccer/new-york-cosmos/">New York Cosmos</a></li>
	<li id="menu-item-15715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15715"><a href="https://www.nysportsday.com/category/soccer/new-york-red-bulls/">New York Red Bulls</a></li>
	<li id="menu-item-16038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16038"><a href="https://www.nysportsday.com/category/soccer/nycfc/">NYC FC</a></li>
</ul>
</li>
<li id="menu-item-15728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15728"><a href="https://www.nysportsday.com/category/college/">College</a>
<ul class="sub-menu">
	<li id="menu-item-15729" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15729"><a href="https://www.nysportsday.com/category/college/college-basketball/">Basketball</a></li>
	<li id="menu-item-15730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15730"><a href="https://www.nysportsday.com/category/college/college-football/">Football</a></li>
</ul>
</li>
<li id="menu-item-56830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56830"><a href="#">Columnists</a>
<ul class="sub-menu">
	<li id="menu-item-56273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56273"><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</a></li>
	<li id="menu-item-56272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56272"><a href="https://www.nysportsday.com/author/hal-bock/">Hal Bock</a></li>
	<li id="menu-item-56279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56279"><a href="https://www.nysportsday.com/author/leslie-treff/">Leslie Treff</a></li>
	<li id="menu-item-56276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56276"><a href="https://www.nysportsday.com/author/jeff-moeller/">Jeff Moeller</a></li>
	<li id="menu-item-56277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56277"><a href="https://www.nysportsday.com/author/david-russell/">David Russell</a></li>
	<li id="menu-item-56278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56278"><a href="https://www.nysportsday.com/author/admin/">Joe McDonald</a></li>
	<li id="menu-item-56275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56275"><a href="https://www.nysportsday.com/author/lloyd-carroll/">Lloyd Carroll</a></li>
	<li id="menu-item-56274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56274"><a href="https://www.nysportsday.com/author/howie-karpin/">Howie Karpin</a></li>
</ul>
</li>
<li id="menu-item-15723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15723"><a href="https://www.nysportsday.com/themofo2">Forum</a></li>
</ul></div>		</nav> 

		<div class="search-toggle-wrap">
			<ion-icon name="search"></ion-icon>
		</div>

		<div class="search-form-wrap">
			<form role="search" aria-label="Search for:" method="get" class="search-form" action="https://www.nysportsday.com">
				<label for="search-form-1">
					<input type="search" id="search-form-1" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<button type="submit" class="btn btn-primary search-submit" ><ion-icon name="search"></ion-icon></button>
			</form>
		</div>


	</header>









	<div id="primary" class="content-area">
		<main id="main" class="site-main">

		<article id="post-59090" class="post-59090 post type-post status-publish format-standard has-post-thumbnail hentry category-hockey category-new-york-islanders tag-featured-article series-schwartz-on-sports">

		
	
	<!-- All posts and pages with custom header -->		
		<div class="hero mb-0 post-hero detached-image">
				<div class="bg"></div>
					<div class="container">
				<div class="row justify-content-between">
					<div class="col-md-12">
													<div class="featured-category">
								<a href="https://www.nysportsday.com/category/hockey/new-york-islanders/">
									New York Islanders								</a>
													</div>
						<h1 class="interior-header">Schwartz On Sports: Greg Picker</h1>
						<div class="post-meta">
														<div class="author">
																<div data-bg="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" class="icon rocket-lazyload" style=""></div>
																<div>
									<span class="lbl">Written By:</span>
									<a href="https://www.nysportsday.com/author/peter-schwartz/">
										Peter Schwartz									</a>
								</div>
							</div>
																												<div class="dateblock published">
								<div class="icon">
									<ion-icon name="newspaper-outline"></ion-icon>
								</div>
								<div>
									<span class="lbl">Published:</span>
									Dec 30, 2020								</div>
							</div>
														<div class="dateblock updated">
								<div class="icon">
									<ion-icon name="calendar-outline"></ion-icon>
								</div>
								<div>
									<span class="lbl">Updated:</span>
									Dec 30, 2020								</div>
							</div>	
										
										
								<div class="post-shares hide-mobile">
									<div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
									<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
									<a href="http://twitter.com/share?text=Schwartz On Sports: Greg Picker&url=https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
									<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/&title=Schwartz On Sports: Greg Picker" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a>
								</div>
													</div>
					</div>			
				</div>
			</div>
		</div>


	<!-- All other pages -->
	



	<div class="entry-content">
		<div class="container">
			<div class="row">
				<div class="col-md-12">

								<div class="detached-image">
					<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/Untitled-10.png" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/Untitled-10.png" /></noscript>
											<div class="photo-credit">
							New York Islanders 						</div>
									</div>
				
				<p>Islanders radio analyst Greg Picker joins Peter to talk about the upcoming season and the Isles&#8217; run to the Eastern Conference Final ast season.</p>
<div class="podcast_player"><div class="castos-player dark-mode" data-episode="59090">
	<div class="player">
		<div class="player__main">
			<div class="player__artwork player__artwork-59090">
				<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" title="NY Sports Day" data-lazy-src="https://www.nysportsday.com/wp-content/plugins/seriously-simple-podcasting/assets/images/no-album-art.png"><noscript><img src="https://www.nysportsday.com/wp-content/plugins/seriously-simple-podcasting/assets/images/no-album-art.png" title="NY Sports Day"></noscript>
			</div>
			<div class="player__body">
				<div class="currently-playing">
					<div class="show">
						<strong>NY Sports Day</strong>
					</div>
					<div class="episode-title">Schwartz On Sports: Greg Picker</div>
				</div>
				<div class="play-progress">
					<div class="play-pause-controls">
						<button title="Play" class="play-btn play-btn-59090"><span class="screen-reader-text">Play Episode</span></button>
						<button alt="Pause" class="pause-btn pause-btn-59090 hide"><span class="screen-reader-text">Pause Episode</span></button>
						<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="loader loader-59090 hide" data-lazy-src="https://www.nysportsday.com/wp-content/plugins/seriously-simple-podcasting/assets/css/images/player/images/icon-loader.svg"/><noscript><img src="https://www.nysportsday.com/wp-content/plugins/seriously-simple-podcasting/assets/css/images/player/images/icon-loader.svg" class="loader loader-59090 hide"/></noscript>
					</div>
					<div>
						<audio class="clip clip-59090">
							<source loop preload="none" src="https://episodes.castos.com/nysportsday/NYI-Greg-Picker-123020.mp3">
						</audio>
						<div class="progress progress-59090" title="Seek">
							<span class="progress__filled progress__filled-59090"></span>
						</div>
						<div class="playback playback-59090">
							<div class="playback__controls">
								<button class="player-btn__volume player-btn__volume-59090" title="Mute/Unmute"><span class="screen-reader-text">Mute/Unmute Episode</span></button>
								<button data-skip="-10" class="player-btn__rwd" title="Rewind 10 seconds"><span class="screen-reader-text">Rewind 10 Seconds</span></button>
								<button data-speed="1" class="player-btn__speed player-btn__speed-59090" title="Playback Speed">1x</button>
								<button data-skip="30" class="player-btn__fwd" title="Fast Forward 30 seconds"><span class="screen-reader-text">Fast Forward 30 seconds</span></button>
							</div>
							<div class="playback__timers">
								<time id="timer-59090">00:00</time>
								<span>/</span>
								<!-- We need actual duration here from the server -->
								<time id="duration-59090">00:21:26</time>
							</div>
						</div>
					</div>
				</div>
				<nav class="player-panels-nav">
					<button class="subscribe-btn" id="subscribe-btn-59090" title="Subscribe">Subscribe</button>
					<button class="share-btn" id="share-btn-59090" title="Share">Share</button>
				</nav>
			</div>
		</div>
	</div>
	<div class="player-panels player-panels-59090">
		<div class="subscribe player-panel subscribe-59090">
			<div class="close-btn close-btn-59090">
				<span></span>
				<span></span>
			</div>
			<div class="panel__inner">
				<div class="subscribe-icons">
									</div>
				<div class="player-panel-row">
					<div class="title">
						RSS Feed
					</div>
					<div>
						<input value="https://www.nysportsday.com/feed/podcast/schwartz-on-sports" class="input-rss input-rss-59090" />
					</div>
					<button class="copy-rss copy-rss-59090"></button>
				</div>
			</div>
		</div>
		<div class="share share-59090 player-panel">
			<div class="close-btn close-btn-59090">
				<span></span>
				<span></span>
			</div>
			<div class="player-panel-row">
				<div class="title">
					Share
				</div>
				<div class="icons-holder">
					<a href="https://www.facebook.com/sharer/sharer.php?u=https://episodes.castos.com/nysportsday/NYI-Greg-Picker-123020.mp3&t=Schwartz On Sports: Greg Picker"
					   target="_blank" class="share-icon facebook" title="Share on Facebook">
						<span></span>
					</a>
					<a href="https://twitter.com/intent/tweet?text=https://episodes.castos.com/nysportsday/NYI-Greg-Picker-123020.mp3&url=Schwartz On Sports: Greg Picker"
					   target="_blank" class="share-icon twitter" title="Share on Twitter">
						<span></span>
					</a>
					<a href="https://episodes.castos.com/nysportsday/NYI-Greg-Picker-123020.mp3"
					   target="_blank" class="share-icon download" title="Download" download>
						<span></span>
					</a>
				</div>
			</div>
			<div class="player-panel-row">
				<div class="title">
					Link
				</div>
				<div>
					<input value="https://www.nysportsday.com/?post_type=post&p=59090" class="input-link input-link-59090"/>
				</div>
				<button class="copy-link copy-link-59090"></button>
			</div>
			<div class="player-panel-row">
				<div class="title">
					Embed
				</div>
				<div style="height: 10px;">
					<input type="text" value='<blockquote class="wp-embedded-content"><a href="https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/">Schwartz On Sports: Greg Picker</a></blockquote>
<script type='text/javascript'>
<!--//--><![CDATA[//><!--
		/*! This file is auto-generated */
		!function(d,l){"use strict";var e=!1,o=!1;if(l.querySelector)if(d.addEventListener)e=!0;if(d.wp=d.wp||{},!d.wp.receiveEmbedMessage)if(d.wp.receiveEmbedMessage=function(e){var t=e.data;if(t)if(t.secret||t.message||t.value)if(!/[^a-zA-Z0-9]/.test(t.secret)){var r,a,i,s,n,o=l.querySelectorAll('iframe[data-secret="'+t.secret+'"]'),c=l.querySelectorAll('blockquote[data-secret="'+t.secret+'"]');for(r=0;r<c.length;r++)c[r].style.display="none";for(r=0;r<o.length;r++)if(a=o[r],e.source===a.contentWindow){if(a.removeAttribute("style"),"height"===t.message){if(1e3<(i=parseInt(t.value,10)))i=1e3;else if(~~i<200)i=200;a.height=i}if("link"===t.message)if(s=l.createElement("a"),n=l.createElement("a"),s.href=a.getAttribute("src"),n.href=t.value,n.host===s.host)if(l.activeElement===a)d.top.location.href=t.value}}},e)d.addEventListener("message",d.wp.receiveEmbedMessage,!1),l.addEventListener("DOMContentLoaded",t,!1),d.addEventListener("load",t,!1);function t(){if(!o){o=!0;var e,t,r,a,i=-1!==navigator.appVersion.indexOf("MSIE 10"),s=!!navigator.userAgent.match(/Trident.*rv:11\./),n=l.querySelectorAll("iframe.wp-embedded-content");for(t=0;t<n.length;t++){if(!(r=n[t]).getAttribute("data-secret"))a=Math.random().toString(36).substr(2,10),r.src+="#?secret="+a,r.setAttribute("data-secret",a);if(i||s)(e=r.cloneNode(!0)).removeAttribute("security"),r.parentNode.replaceChild(e,r)}}}}(window,document);
//--><!]]&gt;
</script><iframe loading="lazy" sandbox="allow-scripts" security="restricted" src="about:blank" width="500" height="350" title="&#8220;Schwartz On Sports: Greg Picker&#8221; &#8212; NY Sports Day" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" class="wp-embedded-content" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/embed/"></iframe><noscript><iframe sandbox="allow-scripts" security="restricted" src="https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/embed/" width="500" height="350" title="&#8220;Schwartz On Sports: Greg Picker&#8221; &#8212; NY Sports Day" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" class="wp-embedded-content"></iframe></noscript>'
					       class="input-embed input-embed-59090"/>
				</div>
				<button class="copy-embed copy-embed-59090"></button>
			</div>
		</div>
	</div>
</div>
</div><div class="podcast_meta"><aside><p><a href="https://www.nysportsday.com/podcast-download/59090/schwartz-on-sports-greg-picker.mp3?ref=download" title="Schwartz On Sports: Greg Picker " class="podcast-meta-download">Download file</a> | <a href="https://www.nysportsday.com/podcast-download/59090/schwartz-on-sports-greg-picker.mp3?ref=new_window" target="_blank" title="Schwartz On Sports: Greg Picker " class="podcast-meta-new-window">Play in new window</a> | <span class="podcast-meta-duration">Duration: 00:21:26</span> | <span class="podcast-meta-date">Recorded on December 30, 2020</span></p></aside></div>				</div>
			</div>
		</div>

		<div class="post-shares show-mobile">
			<div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
			<a href="http://twitter.com/share?text=Schwartz On Sports: Greg Picker&url=https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
			<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2020/12/30/schwartz-on-sports-greg-picker/&title=Schwartz On Sports: Greg Picker" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a>
		</div>
		
				
	<div class="container mt-4">
		<div class="row">
			<div class="col-md-12">
				<div class="author-box card">
					<h5 class="card-header">About the Author</h5>	
					<div class="card-body">
												<div class="avatar pr-3">
							<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" /></noscript>
						</div>	
												<div class="info">					
							<h3><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</h3></a>
							<div class="bio">
								Peter covers the Islanders for New York Sports Day while also writing about general sports in the New York/New Jersey area.  In addition to his column, Peter also hosts his “Schwartz On Sports” podcast as he interviews players, coaches, and other sports personalities. He is also currently a sports anchor for WFAN Radio, CBS Sports Radio and WCBS 880 radio while also serving as the public address announcer for the New York Cosmos soccer club.  Peter spent 8 years as the radio play by play voice for the New York Dragons of the Arena Football League. He was also the radio play by play announcer for the XFL’s NY/NJ Hitmen in 2001 and the radio play by play announcer for the New York Saints of the Major Indoor Lacrosse League from 1993 to 1996.							</div>
						</div>
					</div>
				</div>					
			</div>
		</div>
	</div>




	</div>

</article>
		</main><!-- #main -->
	</div><!-- #primary -->

<div class="social-row">
  <div class="container">
      <div class="row">
        <div class="col-md-4">
          <p>Get connected with us on Social Media</p>
        </div>
        <div class="col-md-8 socials">
           <a href="https://www.facebook.com/nysportsday"><i class="dashicons dashicons-facebook-alt"></i></a><a href="https://twitter.com/nysportsday"><i class="dashicons dashicons-twitter"></i></a><a href="https://www.instagram.com/nysportsday/"><i class="dashicons dashicons-instagram"></i></a><a href="https://www.youtube.com/user/NYSportsDay"><i class="dashicons dashicons-googleplus"></i></a>
        </div>
      </div>
    </div>
</div>
<footer class="footer-global">
	<div class="container">
		<div class="row">
			<div class="col-md-3">
<h5>NY Sports Day</h5>
<p>NY Sports Day is an independent site that covers New York sports since 2004. We are fully credentialed by all nine major New York sports teams.</p>
</div>
<div class="col-md-3">
<h5>NY Sports</h5>
<ul>
<li><a href="/yankees/">New York Yankees</a></li>
<li><a href="https://www.nysportsday.com/mets/">New York Mets</a></li>
<li><a href="https://www.nysportsday.com/giants/">New York Giants</a></li>
<li><a href="https://www.nysportsday.com/jets/">New York Jets</a></li>
</ul>
</div>
<div class="col-md-3">
<h5>NY Sports</h5>
<ul>
<li><a href="https://www.nysportsday.com/islanders/">New York Islanders</a></li>
<li><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li>
<li><a href="https://www.nysportsday.com/knicks/">New York Knicks</a></li>
<li><a href="https://www.nysportsday.com/nets/">New Jersey Nets</a></li>
</ul>
</div>
<div class="col-md-3">
<h5>Popular Pages</h5>
<ul>
<li><a href="https://www.nysportsday.com/sports-betting/">New York Sports Betting</a></li>
<li><a href="https://www.nysportsday.com/online-casinos/">NY Online Casinos</a></li>
<li><a href="https://www.nysportsday.com/nj/">NJ Online Gambling</a></li>
<li><a href="https://www.nysportsday.com/sports-betting/draftkings/">Draftkings Sportsbook Promo Code</a></li>
</ul>
</div>
		</div>
	</div>
</footer>

<div class="footer-copyright">
Copyright © 2020 NYSportsDay - All rights reserved. <a href="https://www.nysportsday.com/about/">About </a> | <a href="https://www.nysportsday.com/contact/">Contact </a> | <a href="https://www.nysportsday.com/privacy-policy/">Privacy Policy</a> 

</div>

<div class="modal fade" id="gameModal" tabindex="-1" role="dialog" aria-labelledby="gameModalLabel" aria-hidden="true">
  <div class="modal-dialog modal-dialog-centered" role="document">
    <div class="modal-content">
      <div class="modal-header">
        <h5 class="modal-title" id="gameModalLabel">Modal title</h5>
        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
          <span aria-hidden="true">&times;</span>
        </button>
      </div>
      <div class="modal-body">
       <iframe width="100%" height="550" src=""></iframe>
      </div>
    </div>
  </div>
</div>




<script type='text/javascript' id='ta_main_js-js-extra'>
/* <![CDATA[ */
var thirsty_global_vars = {"home_url":"\/\/www.nysportsday.com","ajax_url":"https:\/\/www.nysportsday.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"visit","link_prefixes":["recommends","visit"],"post_id":"59090","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/* ]]> */
</script>

<script type='text/javascript' src='https://code.jquery.com/jquery-3.1.0.js?ver=20151215' id='jqueryslim-js'></script>




<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.nysportsday.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><script src="https://www.nysportsday.com/wp-content/cache/min/1/4ab819b1d8d809c0dff159591b3ae88c.js" data-minify="1" defer></script><noscript><link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&#038;display=swap" rel="stylesheet"><link rel="stylesheet" href="https://www.nysportsday.com/wp-content/cache/min/1/db55663101302a83e00fc203adc10ed0.css" media="all" data-minify="1" /></noscript></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1609344918 -->