<!doctype html>
<html lang="en-US">
<head>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PK2SCV9');</script>
<!-- End Google Tag Manager --><meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&#038;display=swap" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" rel="preload">
<script type="module" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.esm.js" defer></script>
<script nomodule="" src="https://unpkg.com/ionicons@5.0.0/dist/ionicons/ionicons.js" defer></script>

	<!-- This site is optimized with the Yoast SEO plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Schwartz On Sports: Chris Creamer and Todd Radom - NY Sports Day</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://www.nysportsday.com/wp-content/cache/min/1/cf83acf8b7293212c8998c4ab88f729a.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Schwartz On Sports: Chris Creamer and Todd Radom - NY Sports Day" />
	<meta property="og:description" content="Authors Chris Creamer and Todd Radom join Peter to talk about their new book &#8220;Fabric [&hellip;]" />
	<meta property="og:url" content="https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/" />
	<meta property="og:site_name" content="NY Sports Day" />
	<meta property="article:published_time" content="2020-10-30T15:54:38+00:00" />
	<meta property="article:modified_time" content="2020-10-30T15:55:16+00:00" />
	<meta property="og:image" content="https://www.nysportsday.com/wp-content/uploads/FABRIC-OF-THE-GAME-COVER_07.27.2020-scaled.jpg" />
	<meta property="og:image:width" content="2560" />
	<meta property="og:image:height" content="2283" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.nysportsday.com/#website","url":"https://www.nysportsday.com/","name":"NY Sports Day","description":"Your Gotham Sports News Source","potentialAction":[{"@type":"SearchAction","target":"https://www.nysportsday.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/#primaryimage","inLanguage":"en-US","url":"https://www.nysportsday.com/wp-content/uploads/FABRIC-OF-THE-GAME-COVER_07.27.2020-scaled.jpg","width":2560,"height":2283},{"@type":"WebPage","@id":"https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/#webpage","url":"https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/","name":"Schwartz On Sports: Chris Creamer and Todd Radom - NY Sports Day","isPartOf":{"@id":"https://www.nysportsday.com/#website"},"primaryImageOfPage":{"@id":"https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/#primaryimage"},"datePublished":"2020-10-30T15:54:38+00:00","dateModified":"2020-10-30T15:55:16+00:00","author":{"@id":"https://www.nysportsday.com/#/schema/person/71cc1a2589b984bf6268b028c2125d34"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/"]}]},{"@type":"Person","@id":"https://www.nysportsday.com/#/schema/person/71cc1a2589b984bf6268b028c2125d34","name":"Peter Schwartz","image":{"@type":"ImageObject","@id":"https://www.nysportsday.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ce3b9490c1a6bb7f8acf77b7871ed35a?s=96&d=retro&r=g","caption":"Peter Schwartz"},"description":"Peter covers the Islanders for New York Sports Day while also writing about general sports in the New York/New Jersey area. In addition to his column, Peter also hosts his \u201cSchwartz On Sports\u201d podcast as he interviews players, coaches, and other sports personalities. He is also currently a sports anchor for WFAN Radio, CBS Sports Radio and WCBS 880 radio while also serving as the public address announcer for the New York Cosmos soccer club. Peter spent 8 years as the radio play by play voice for the New York Dragons of the Arena Football League. He was also the radio play by play announcer for the XFL\u2019s NY/NJ Hitmen in 2001 and the radio play by play announcer for the New York Saints of the Major Indoor Lacrosse League from 1993 to 1996."}]}</script>
	<!-- / Yoast SEO plugin. -->












<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.nysportsday.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type='text/javascript' src='https://www.nysportsday.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>

<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.nysportsday.com/feed/podcast" />

      <meta name="onesignal" content="wordpress-plugin"/>
            
<link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.nysportsday.com/wp-content/uploads/cropped-nysportsday-512-270x270.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>

<body class="post-template-default single single-post postid-58370 single-format-standard">

	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PK2SCV9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<header class="site-header">

				<div class="mega-menu">
		<div class="logo-col"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" /></noscript></div>
<div class="container">
<div class="row">
<div class="col-md-6">
<h4 class="mm-nav-label">NY Baseball &amp; Football</h4>
<ul>
<li><a href="/yankees/">New York Yankees</a></li>
<li><a href="https://www.nysportsday.com/category/baseball/new-york-mets/">New York Mets</a></li>
<li><a href="https://www.nysportsday.com/category/football/new-york-giants/">New York Giants</a></li>
<li><a href="https://www.nysportsday.com/category/football/new-york-jets/">New York Jets</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">NY Hockey &amp; Basketball</h4>
<ul>
<li><a href="https://www.nysportsday.com/category/hockey/new-york-islanders/">New York Islanders</a></li>
<li><a href="https://www.nysportsday.com/category/hockey/new-york-rangers/">New York Rangers</a></li>
<li><a href="https://www.nysportsday.com/category/basketball/new-york-knicks/">New York Knicks</a></li>
<li><a href="https://www.nysportsday.com/category/basketball/new-jersey-nets/">New Jersey Nets</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">Other</h4>
<ul>
<li><a href="https://www.nysportsday.com/new-york-sports-betting/">New York Sports Betting</a></li>
</ul>
</div>
<div class="col-md-6">
<h4 class="mm-nav-label">Contact</h4>
<ul>
<li><a href="https://www.nysportsday.com/about/">About</a></li>
<li><a href="https://www.nysportsday.com/contact-us/">Contact</a></li>
</ul>
</div>
</div>
</div>
		</div>
		
	
		<div class="mega-menu-toggle">
			<div class="menu">
				<div class="bar"></div>
				<div class="bar"></div>
				<div class="bar"> </div>
			</div>
		</div>


	
		<div class="site-branding">
			<a href="https://www.nysportsday.com/" rel="home">
				<span class="logo-m"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="nysportsday.com" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png"/><noscript><img src="https://www.nysportsday.com/wp-content/uploads/nysportslogo.png" alt="nysportsday.com"/></noscript></span>
			</a>
		</div>	

		<nav id="site-navigation" class="main-navigation">
			<div class="menu-menu-container"><ul id="primary-menu-left" class="menu"><li id="menu-item-15689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-15689"><a href="https://www.nysportsday.com/">Home</a></li>
<li id="menu-item-15690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15690"><a href="https://www.nysportsday.com/category/baseball/">Baseball</a>
<ul class="sub-menu">
	<li id="menu-item-56865" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56865"><a href="https://www.nysportsday.com/yankees/">NY Yankees</a></li>
	<li id="menu-item-56864" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56864"><a href="https://www.nysportsday.com/mets/">NY Mets</a></li>
</ul>
</li>
<li id="menu-item-15693" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15693"><a href="https://www.nysportsday.com/category/football/">Football</a>
<ul class="sub-menu">
	<li id="menu-item-56862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56862"><a href="https://www.nysportsday.com/jets/">NY Jets News</a></li>
	<li id="menu-item-56863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56863"><a href="https://www.nysportsday.com/giants/">NY Giants</a></li>
</ul>
</li>
<li id="menu-item-15696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15696"><a href="https://www.nysportsday.com/category/basketball/">Basketball</a>
<ul class="sub-menu">
	<li id="menu-item-56860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56860"><a href="https://www.nysportsday.com/nets/">Brooklyn Nets</a></li>
	<li id="menu-item-56861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56861"><a href="https://www.nysportsday.com/knicks/">NY Knicks</a></li>
</ul>
</li>
<li id="menu-item-15699" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-15699"><a href="https://www.nysportsday.com/category/hockey/">Hockey</a>
<ul class="sub-menu">
	<li id="menu-item-56858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56858"><a href="https://www.nysportsday.com/islanders/">NY Islanders</a></li>
	<li id="menu-item-56859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56859"><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li>
	<li id="menu-item-56857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56857"><a href="https://www.nysportsday.com/devils/">NJ Devils</a></li>
</ul>
</li>
<li id="menu-item-15711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15711"><a href="https://www.nysportsday.com/category/other-sports/">Other</a>
<ul class="sub-menu">
	<li id="menu-item-56833" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56833"><a href="https://www.nysportsday.com/sports-betting/">NY Sports Betting</a></li>
	<li id="menu-item-56831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56831"><a href="https://www.nysportsday.com/online-casinos/">NY Online Casinos</a></li>
	<li id="menu-item-56832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56832"><a href="https://www.nysportsday.com/nj/">NJ Online Gambling</a></li>
	<li id="menu-item-15718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15718"><a href="https://www.nysportsday.com/category/tennis/us-open-tennis/">US Open Tennis</a></li>
	<li id="menu-item-15712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15712"><a href="https://www.nysportsday.com/category/boxing/">Boxing</a></li>
	<li id="menu-item-15713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15713"><a href="https://www.nysportsday.com/category/golf/">Golf</a></li>
	<li id="menu-item-15714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15714"><a href="https://www.nysportsday.com/category/soccer/new-york-cosmos/">New York Cosmos</a></li>
	<li id="menu-item-15715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15715"><a href="https://www.nysportsday.com/category/soccer/new-york-red-bulls/">New York Red Bulls</a></li>
	<li id="menu-item-16038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16038"><a href="https://www.nysportsday.com/category/soccer/nycfc/">NYC FC</a></li>
</ul>
</li>
<li id="menu-item-15728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15728"><a href="https://www.nysportsday.com/category/college/">College</a>
<ul class="sub-menu">
	<li id="menu-item-15729" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15729"><a href="https://www.nysportsday.com/category/college/college-basketball/">Basketball</a></li>
	<li id="menu-item-15730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15730"><a href="https://www.nysportsday.com/category/college/college-football/">Football</a></li>
</ul>
</li>
<li id="menu-item-56830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56830"><a href="#">Columnists</a>
<ul class="sub-menu">
	<li id="menu-item-56273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56273"><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</a></li>
	<li id="menu-item-56272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56272"><a href="https://www.nysportsday.com/author/hal-bock/">Hal Bock</a></li>
	<li id="menu-item-56279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56279"><a href="https://www.nysportsday.com/author/leslie-treff/">Leslie Treff</a></li>
	<li id="menu-item-56276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56276"><a href="https://www.nysportsday.com/author/jeff-moeller/">Jeff Moeller</a></li>
	<li id="menu-item-56277" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56277"><a href="https://www.nysportsday.com/author/david-russell/">David Russell</a></li>
	<li id="menu-item-56278" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56278"><a href="https://www.nysportsday.com/author/admin/">Joe McDonald</a></li>
	<li id="menu-item-56275" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56275"><a href="https://www.nysportsday.com/author/lloyd-carroll/">Lloyd Carroll</a></li>
	<li id="menu-item-56274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56274"><a href="https://www.nysportsday.com/author/howie-karpin/">Howie Karpin</a></li>
</ul>
</li>
<li id="menu-item-15723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15723"><a href="https://www.nysportsday.com/themofo2">Forum</a></li>
</ul></div>		</nav> 

		<div class="search-toggle-wrap">
			<ion-icon name="search"></ion-icon>
		</div>

		<div class="search-form-wrap">
			<form role="search" aria-label="Search for:" method="get" class="search-form" action="https://www.nysportsday.com">
				<label for="search-form-1">
					<input type="search" id="search-form-1" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<button type="submit" class="btn btn-primary search-submit" ><ion-icon name="search"></ion-icon></button>
			</form>
		</div>


	</header>









	<div id="primary" class="content-area">
		<main id="main" class="site-main">

		<article id="post-58370" class="post-58370 post type-post status-publish format-standard has-post-thumbnail hentry category-hockey tag-featured-article series-schwartz-on-sports">

		
	
	<!-- All posts and pages with custom header -->		
		<div class="hero mb-0 post-hero detached-image">
				<div class="bg"></div>
					<div class="container">
				<div class="row justify-content-between">
					<div class="col-md-12">
													<div class="featured-category">
								<a href="https://www.nysportsday.com/category/hockey/">
									Hockey								</a>
													</div>
						<h1 class="interior-header">Schwartz On Sports: Chris Creamer and Todd Radom</h1>
						<div class="post-meta">
														<div class="author">
																<div data-bg="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" class="icon rocket-lazyload" style=""></div>
																<div>
									<span class="lbl">Written By:</span>
									<a href="https://www.nysportsday.com/author/peter-schwartz/">
										Peter Schwartz									</a>
								</div>
							</div>
																												<div class="dateblock published">
								<div class="icon">
									<ion-icon name="newspaper-outline"></ion-icon>
								</div>
								<div>
									<span class="lbl">Published:</span>
									Oct 30, 2020								</div>
							</div>
														<div class="dateblock updated">
								<div class="icon">
									<ion-icon name="calendar-outline"></ion-icon>
								</div>
								<div>
									<span class="lbl">Updated:</span>
									Oct 30, 2020								</div>
							</div>	
										
										
								<div class="post-shares hide-mobile">
									<div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
									<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
									<a href="http://twitter.com/share?text=Schwartz On Sports: Chris Creamer and Todd Radom&url=https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
									<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/&title=Schwartz On Sports: Chris Creamer and Todd Radom" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a>
								</div>
													</div>
					</div>			
				</div>
			</div>
		</div>


	<!-- All other pages -->
	



	<div class="entry-content">
		<div class="container">
			<div class="row">
				<div class="col-md-12">

								<div class="detached-image">
					<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/FABRIC-OF-THE-GAME-COVER_07.27.2020-1024x913.jpg" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/FABRIC-OF-THE-GAME-COVER_07.27.2020-1024x913.jpg" /></noscript>
											<div class="photo-credit">
							Chris Creamer and Todd Radom						</div>
									</div>
				
				<p>Authors Chris Creamer and Todd Radom join Peter to talk about their new book &#8220;Fabric Of The Game-The Stories Behind The NHL&#8217;s Names, Logos, and Uniforms&#8221;.</p>
<div class="podcast_player">						<div class="ssp-player ssp-player-large" data-player-instance-number="1" data-player-waveform-colour="#fff" data-player-waveform-progress-colour="#00d4f7" data-source-file="https://www.nysportsday.com/podcast-player/58370/schwartz-on-sports-chris-creamer-and-todd-radom.mp3" id="ssp_player_id_1"  style="background: #222222;">
															<div class="ssp-album-art-container">
									<div class="ssp-album-art" style="background: url( https://www.nysportsday.com/wp-content/plugins/seriously-simple-podcasting/assets/images/no-album-art.png ) center center no-repeat; -webkit-background-size: cover;background-size: cover;"></div>
								</div>
														<div style="overflow: hidden">
								<div class="ssp-player-inner" style="overflow: hidden;">
									<div class="ssp-player-info">
										<div style="width: 80%; float:left;">
											<h3 class="ssp-player-title episode-title">
												Schwartz On Sports: Chris Creamer and Todd Radom<br><span class="ssp-player-series">Schwartz on Sports</span>											</h3>
										</div>
										<div class="ssp-download-episode" style="overflow: hidden;text-align:right;"></div>
										<div>&nbsp;</div>
										<div class="ssp-media-player">
											<div class="ssp-custom-player-controls">
												<div class="ssp-play-pause" id="ssp-play-pause">
													<span class="ssp-icon ssp-icon-play_icon">&nbsp;</span>
												</div>
												<div class="ssp-wave-form">
													<div class="ssp-inner">
														<div data-waveform-id="waveform_1" id="waveform1" class="ssp-wave"></div>
													</div>
												</div>
												<div class="ssp-time-volume">
													<div class="ssp-duration">
														<span id="sspPlayedDuration">00:00</span> / <span id="sspTotalDuration">00:26:39</span>
													</div>
													<div class="ssp-volume">
														<div class="ssp-back-thirty-container">
															<div class="ssp-back-thirty-control" id="ssp-back-thirty">
																<i class="ssp-icon icon-replay">&nbsp;</i>
															</div>
														</div>
														<div class="ssp-playback-speed-label-container">
															<div class="ssp-playback-speed-label-wrapper">
																<span data-playback-speed-id="ssp_playback_speed_1" id="ssp_playback_speed1" data-ssp-playback-rate="1">1X</span>
															</div>
														</div>
														<div class="ssp-download-container">
															<div class="ssp-download-control">
																<a class="ssp-episode-download" href="https://www.nysportsday.com/podcast-download/58370/schwartz-on-sports-chris-creamer-and-todd-radom.mp3?ref=download" target="_blank"><i class="ssp-icon icon-cloud-download">&nbsp;</i></a>
															</div>
														</div>
													</div>
												</div>
											</div>
										</div>
									</div>
								</div>
							</div>
						</div>
						</div><div class="podcast_meta"><aside><p><a href="https://www.nysportsday.com/podcast-download/58370/schwartz-on-sports-chris-creamer-and-todd-radom.mp3?ref=download" title="Schwartz On Sports: Chris Creamer and Todd Radom " class="podcast-meta-download">Download file</a> | <a href="https://www.nysportsday.com/podcast-download/58370/schwartz-on-sports-chris-creamer-and-todd-radom.mp3?ref=new_window" target="_blank" title="Schwartz On Sports: Chris Creamer and Todd Radom " class="podcast-meta-new-window">Play in new window</a> | <span class="podcast-meta-duration">Duration: 00:26:39</span> | <span class="podcast-meta-date">Recorded on October 30, 2020</span></p><p>Subscribe: <a href="https://itunes.apple.com/us/podcast/schwartz-on-sports/id1438045201?mt=2" target="_blank" title="iTunes" class="podcast-meta-itunes">iTunes</a> | <a href="https://www.stitcher.com/s?fid=243792&#038;refid=stpr" target="_blank" title="Stitcher" class="podcast-meta-itunes">Stitcher</a> | <a href="https://playmusic.app.goo.gl/?ibi=com.google.PlayMusic&#038;isi=691797987&#038;ius=googleplaymusic&#038;apn=com.google.android.music&#038;link=https://play.google.com/music/m/Is35lus37ny2h4g4f5xb7hkw4ly?t%3DSchwartz_on_Sports%26pcampaignid%3DMKT-na-all-co-pr-mu-pod-16" target="_blank" title="Google Play" class="podcast-meta-itunes">Google Play</a> | <a href="https://open.spotify.com/show/1AnbitcIuhjmJeoy6yIL5w" target="_blank" title="Spotify" class="podcast-meta-itunes">Spotify</a></p></aside></div>				</div>
			</div>
		</div>

		<div class="post-shares show-mobile">
			<div class="share-box sharing"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Share</div>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/" target="_blank"><div class="share-box facebook-share"><i class="dashicons dashicons-facebook-alt"></i> <span class="seperator">|</span> Facebook</div></a>
			<a href="http://twitter.com/share?text=Schwartz On Sports: Chris Creamer and Todd Radom&url=https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/" target="_blank"><div class="share-box twitter-share"><i class="dashicons dashicons-twitter"></i> <span class="seperator">|</span> Twitter</div></a>
			<a href="https://www.reddit.com/submit?url=https://www.nysportsday.com/2020/10/30/schwartz-on-sports-chris-creamer-and-todd-radom/&title=Schwartz On Sports: Chris Creamer and Todd Radom" target="_blank"><div class="share-box reddit-share"><i class="dashicons dashicons-share"></i> <span class="seperator">|</span> Reddit</div></a>
		</div>
		
				
	<div class="container mt-4">
		<div class="row">
			<div class="col-md-12">
				<div class="author-box card">
					<h5 class="card-header">About the Author</h5>	
					<div class="card-body">
												<div class="avatar pr-3">
							<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" /><noscript><img src="https://www.nysportsday.com/wp-content/uploads/peter-schwartz-photo.jpg" /></noscript>
						</div>	
												<div class="info">					
							<h3><a href="https://www.nysportsday.com/author/peter-schwartz/">Peter Schwartz</h3></a>
							<div class="bio">
								Peter covers the Islanders for New York Sports Day while also writing about general sports in the New York/New Jersey area.  In addition to his column, Peter also hosts his “Schwartz On Sports” podcast as he interviews players, coaches, and other sports personalities. He is also currently a sports anchor for WFAN Radio, CBS Sports Radio and WCBS 880 radio while also serving as the public address announcer for the New York Cosmos soccer club.  Peter spent 8 years as the radio play by play voice for the New York Dragons of the Arena Football League. He was also the radio play by play announcer for the XFL’s NY/NJ Hitmen in 2001 and the radio play by play announcer for the New York Saints of the Major Indoor Lacrosse League from 1993 to 1996.							</div>
						</div>
					</div>
				</div>					
			</div>
		</div>
	</div>




	</div>

</article>
		</main><!-- #main -->
	</div><!-- #primary -->

<div class="social-row">
  <div class="container">
      <div class="row">
        <div class="col-md-4">
          <p>Get connected with us on Social Media</p>
        </div>
        <div class="col-md-8 socials">
           <a href="https://www.facebook.com/nysportsday"><i class="dashicons dashicons-facebook-alt"></i></a><a href="https://twitter.com/nysportsday"><i class="dashicons dashicons-twitter"></i></a><a href="https://www.instagram.com/nysportsday/"><i class="dashicons dashicons-instagram"></i></a><a href="https://www.youtube.com/user/NYSportsDay"><i class="dashicons dashicons-googleplus"></i></a>
        </div>
      </div>
    </div>
</div>
<footer class="footer-global">
	<div class="container">
		<div class="row">
			<div class="col-md-3">
<h5>NY Sports Day</h5>
<p>NY Sports Day is an independent site that covers New York sports since 2004. We are fully credentialed by all nine major New York sports teams.</p>
</div>
<div class="col-md-3">
<h5>NY Sports</h5>
<ul>
<li><a href="/yankees/">New York Yankees</a></li>
<li><a href="https://www.nysportsday.com/mets/">New York Mets</a></li>
<li><a href="https://www.nysportsday.com/giants/">New York Giants</a></li>
<li><a href="https://www.nysportsday.com/jets/">New York Jets</a></li>
</ul>
</div>
<div class="col-md-3">
<h5>NY Sports</h5>
<ul>
<li><a href="https://www.nysportsday.com/islanders/">New York Islanders</a></li>
<li><a href="https://www.nysportsday.com/rangers/">New York Rangers</a></li>
<li><a href="https://www.nysportsday.com/knicks/">New York Knicks</a></li>
<li><a href="https://www.nysportsday.com/nets/">New Jersey Nets</a></li>
</ul>
</div>
<div class="col-md-3">
<h5>Popular Pages</h5>
<ul>
<li><a href="https://www.nysportsday.com/sports-betting/">New York Sports Betting</a></li>
<li><a href="https://www.nysportsday.com/online-casinos/">NY Online Casinos</a></li>
<li><a href="https://www.nysportsday.com/nj/">NJ Online Gambling</a></li>
<li><a href="https://www.nysportsday.com/sports-betting/draftkings/">Draftkings Sportsbook Promo Code</a></li>
</ul>
</div>
		</div>
	</div>
</footer>

<div class="footer-copyright">
Copyright © 2020 NYSportsDay - All rights reserved. <a href="https://www.nysportsday.com/about/">About </a> | <a href="https://www.nysportsday.com/contact/">Contact </a> | <a href="https://www.nysportsday.com/privacy-policy/">Privacy Policy</a> 

</div>

<div class="modal fade" id="gameModal" tabindex="-1" role="dialog" aria-labelledby="gameModalLabel" aria-hidden="true">
  <div class="modal-dialog modal-dialog-centered" role="document">
    <div class="modal-content">
      <div class="modal-header">
        <h5 class="modal-title" id="gameModalLabel">Modal title</h5>
        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
          <span aria-hidden="true">&times;</span>
        </button>
      </div>
      <div class="modal-body">
       <iframe width="100%" height="550" src=""></iframe>
      </div>
    </div>
  </div>
</div>

		<style type="text/css">
			.ssp-wave wave wave {
				background: #00d4f7 !important;
			}
		</style>
		




<script type='text/javascript' id='ta_main_js-js-extra'>
/* <![CDATA[ */
var thirsty_global_vars = {"home_url":"\/\/www.nysportsday.com","ajax_url":"https:\/\/www.nysportsday.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"visit","link_prefixes":["recommends","visit"],"post_id":"58370","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/* ]]> */
</script>





		<link rel="preload" href="//fonts.googleapis.com/css?family=Roboto:400,700&v=2.2.3" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'"/>
		
		
		
					
		<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.nysportsday.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><script src="https://www.nysportsday.com/wp-content/cache/min/1/20d8297e0b6da13bbcfdeb213667c7b9.js" data-minify="1" defer></script><noscript><link href="https://fonts.googleapis.com/css2?family=Montserrat:wght@200;300;400;500;600;700;800;900&#038;display=swap" rel="stylesheet"><link rel="stylesheet" href="https://www.nysportsday.com/wp-content/cache/min/1/cf83acf8b7293212c8998c4ab88f729a.css" media="all" data-minify="1" /><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto:400,700&v=2.2.3"/></noscript></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1604073320 -->